#9 Make-error

v0.5
closed
nobody
None
5
2007-01-21
2006-12-26
overt2here
No

Hi.

When compiling the project in Kontrollerlab, (I've included several files), I always get the error "redefinition function xyz". But compiling this file
with the makefile it works.

Please fix this bug. Thanks.

over2there

Discussion

  • Martin Strasser

    Martin Strasser - 2006-12-26

    Logged In: YES
    user_id=902327
    Originator: NO

    I haven't experienced such problems yet. Could You please submit a project directory as e.g. tar.gz to make it easier for us to reconstruct the bug?

    Thank You!
    cadmaniac

     
  • Martin Strasser

    Martin Strasser - 2006-12-26
    • status: open --> pending
     
  • overt2here

    overt2here - 2006-12-27

    Logged In: YES
    user_id=1664921
    Originator: YES

    Sure, I can.

    First of all, this directory was only created for test-reasons. There is no real usage.

    Second, I'll try to discripe the bug: It think the software includes the file files. However, I made a reinclude-stop be the preprocessor, but it doesn't help. When compiling this files in Kontrollerlab, I get always the Error(Let's say xyz is my function.) "Redefinition of function xyz. This is not a prototype."

    Last but not least I'm still using 0.5. and Slax (==>AvrLiveCD - You might know).

    Thanks for your support.

    overthere

    P.s. Please excuse my first post in a horrible language.
    File Added: hardware.rar

     
  • overt2here

    overt2here - 2006-12-27
    • status: pending --> open
     
  • overt2here

    overt2here - 2007-01-11

    Logged In: YES
    user_id=1664921
    Originator: YES

    Nothing new?

     
  • Martin Strasser

    Martin Strasser - 2007-01-11

    Logged In: YES
    user_id=902327
    Originator: NO

    I've had a HD crash some days ago... Hopefully on the weekend I will be able to fix that bug. I had some problems with Your sources before (missing libs on my system), but I think I can fix that. But, until now, I haven't found the bug.

     
  • Martin Strasser

    Martin Strasser - 2007-01-18

    Logged In: YES
    user_id=902327
    Originator: NO

    Hi,

    there is no uart.h and uart.c included in the project. As soon as one includes the file with:
    #include "uart.h"
    instead of
    #include <uart.h>
    and one includes the rs232software.c with #include "rs232software.c"
    instead of #inculde <rs232software.c>
    There is no such error. But compiling fails anyway because there are undefined constants.

    I've now tried to make the project with the makefile using the live AVR CD. That also has failed.

    Since this seems not to be a KontrollerLab bug, i set it to "pending" now.

     
  • Martin Strasser

    Martin Strasser - 2007-01-18
    • status: open --> pending
     
  • overt2here

    overt2here - 2007-01-19

    Logged In: YES
    user_id=1664921
    Originator: YES

    Hi.

    thats funny. I'll doublecheck it tomorrow again, and than I'll
    write again. But I'm sure it worked with the make command.
    It's also possible that I posted the wrong data. That would
    be awkward for me...

    Well, we'll se tomorow, where I made the mistake.

    Thanks for your help and a nice weekend.

    overthere

     
  • overt2here

    overt2here - 2007-01-19
    • status: pending --> open
     
  • overt2here

    overt2here - 2007-01-21

    Logged In: YES
    user_id=1664921
    Originator: YES

    Hi.

    I checked it. And I need to tell you that I'm very sorry.
    You were right. That error appers when I included serveral
    files. But I was always clicking "Build project" instead
    of build file. And this was my mistake.

    Sorry for the trouble.

    overthere

     
  • overt2here

    overt2here - 2007-01-21
    • status: open --> closed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks