re-formats source code

Help
Marc
2006-10-31
2013-04-03
  • Marc

    Marc - 2006-10-31

    Hi;

    I've just downloaded the current release for Linux, and was wondering how I stop kompozer from re-formating my souce code when I save?
    I have selected "Retain original source formating"

    Many thanks
    Marc

     
    • StickMaker

      StickMaker - 2006-12-25

      I have KompoZer set to "Retain original source formating" also, but it DOES NOT WORK. All my code is concatenated into one or a few long lines of code which are impossible to tweak in Notepad. This is the MOST SERIOUS problem with KompoZer as I see it now.

      Kaze, best wishes in your efforts!! Wish I was smart enough to help.

       
    • Pietro Gagliardi (andlabs)

      That's why I still plan to use Nvu! That's why I did not like KompoZer the first time I saw it! I do not like very long lines of HTML code that someone who needs to use HTML to overcome the bugs that are *still* unfixed (I can't change the vertical alignment on table rows) which makes it murder to edit! I will file 2 bug reports.

       
    • Eleanora

      Eleanora - 2007-08-05

      Hello

      The problem with NVU was, that it added a new blank line everytime you opened it, which was a pain as well.

      Well Kazé does provide an extension call HandCoder. It can be found here:

      http://fabiwan.kenobi.free.fr/HandCoder/

      Just follow the instructions to install it on your computer.

      Through the extension you you can use any texteditor you like to edit the code.

       
      • Arralen

        Arralen - 2007-10-21

        "HandCoder" is NOT a solution to the problem:
        If I use an HTML-editor with WYSIWYG for my project, I don't want to have to load the page into Notepad if I want to change the sourcecode ... that defeats the purpose of the whole thing at least partly - and I end up with more complicated functionality than I would have if I use a "normal" HTML editor with integrated preview.

         
    • jeffmings

      jeffmings - 2007-11-28

      I have been watching this project from its early days as NVU, and am quite impressed by it. I really like the newer CSS editing features.
      Unfortunately, just one thing keeps me from using it instead of DreamWeaver.  That's right, I think it's useful enough to replace my favorite editor.  It automatically wraps lines that I want left alone, even if I select the retain formatting option.

      I think there is a simple solution.
      Can I somehow specify that the lines should wrap at a much longer length?
      Is there a secret config file that will allow that?
      Just changing this would allow me to start using Kompozer right away.

      Thanks,

      -Jeff Mings

       
    • jeffmings

      jeffmings - 2007-11-30

      Hello,

          I thought I had found the key to keeping Kompozer from wrapping lines on its own.  The file editor.js, in the default profile created for my user in the home directory, has the following setting:

      pref("editor.htmlWrapColumn", 72);

      I thought that setting it to a higher value, like 150, would fix the line wrapping that messes up my source code.  I changed it to 99 in every instance of the file that I could find, but premature line wrapping is unchanged.

      Am I missing something here?

      Fixing the line wrap would make Kompozer so much more useful for me and for many others, I'm sure.

      Thanks in advance,

      -Jeff Mings

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks