#61 Keep Page Formating

0.7.10
open-duplicate
nobody
Editor (27)
8
2009-11-23
2006-12-03
Anonymous
No

When opening a nicely formated page and then saving in the latest version for Komposer it squashes the code together.

Discussion

  • Nobody/Anonymous

    Logged In: NO

    This is indeed very annoying and should have a much higher priority.

     
  • Mauvan

    Mauvan - 2006-12-24

    Logged In: YES
    user_id=1675986
    Originator: NO

    This is indeed very annoying and should have a much higher priority.

     
  • Nobody/Anonymous

    Logged In: NO

    I think so too: much higher priority. :)

    NVU is a bit useless to me with not really "retaining original source formatting" (general options). It should retain manual linebreaks in source code as well (bug request "1621807"?!).

    But I'll help myself with an external source-code editor. It seems that it works.

     
  • Pietro Gagliardi (andlabs)

    Logged In: YES
    user_id=1218098
    Originator: NO

    I will restate this bug fix but with the highest possible priority. Unfortunately, I cannot change the priority.

     
  • Nobody/Anonymous

    Logged In: NO

    Is this the same problem as "messy html formatting"? The problem is that eg Google cannot create a correct index for pages with that code! Wenever a space is repalced by one of these defektive line breaks, google cannot read the word before and after the space! Very bad if you don't find your content with google anymore just because of this unnecessary bug!

     
  • Pietro Gagliardi (andlabs)

    Logged In: YES
    user_id=1218098
    Originator: NO

    It is - but whoever started the post did not make it a critical one. I reposted it with full description of the problem (including code sample) there and gave it as much a criticalness (if that is a word) as possible.

     
  • Eleanora

    Eleanora - 2007-08-05
    • status: open --> closed
     
  • Eleanora

    Eleanora - 2007-08-05

    Logged In: YES
    user_id=1860071
    Originator: NO

    Please install the HandCoder extension together with tidy. KompoZer the same as NVU leaves your code alone.

     
  • Fabien Cazenave (kaze)

    • status: closed --> open-duplicate
     
  • Frédéric Chateaux

    • labels: --> Editor
    • milestone: --> 0.7.10
    • priority: 5 --> 8
     
  • Frédéric Chateaux

    Setting priority to 8 for more visibilty, not for "real" priority.

     
  • Dave Hitchman

    Dave Hitchman - 2009-12-06

    Does anyone have an idea where the 'mess around with my source code' code is within the project, if they do then surely a simple flag around it to switch it off during saving will take about 5 minutes to put in and test. This should be a top priority because it makes my source html unreadable and not understandable when it won't allow me to add whitespac indents and keep them! In fact, I wouldn't have thought it beyond possibility to actually automatically indent the source code during its generation anyway, but at least when I take the trouble to tidy up the generated mess it should leave well alone!

     
  • yukinoroh

    yukinoroh - 2009-12-16

    I have BIG trouble with this bug, specially where Kompozer splits long lines of text with no spaces in the source code. It is very frequent in Japanese, because Japanese has no spaces. The problem is that browsers (ex: Firefox) are programmed to put a space where the line break is. It is not acceptable in Japanese. By having a look at the source code of Japanese pages, I notice that the Japanese text is never split. So obviously until Firefox gets Kompozer-compatible, perhaps fixing Kompozer would be a better idea?

     
  • romantoo

    romantoo - 2010-01-23

    Does 0.8b1 still do it? It has an option to preserve current format.

     
  • yukinoroh

    yukinoroh - 2010-01-27

    Yes, 0.8b1 behaves like 0.8a4 : even with the option to preserve format turned on, switching from Design mode to Source mode or vice versa, and/or saving the document breaks the formatting.
    I believe the reason why this bug has not been noticed by the Japanese so far is that commercial editors do keep the formatting and... that Kompozer was not Japanese ready! I tried to have a colleague use it here and she was reluctant about the English interface. I see that has changed now, so I hope this problem gets the attention it deserves.
    I have submitted a bug report for the Firefox side : https://bugzilla.mozilla.org/show_bug.cgi?id=535485
    But I think that the Mozilla guys are waiting for the CSS standards to change (or are going to have them change) before moving.

     
  • Fabien Cazenave (kaze)

    yukinoroh > yes, I'm aware of the line-wrap problem with Kanjis. I'm working on it, but unfortunately I can't be sure it will be ready for the next release (0.8b2).

     
  • yukinoroh

    yukinoroh - 2010-03-02

    *pings fabiwan*

    I think I will have to run a bash script to remove all line breaks before uploading the files through external ftp software :/

    By the way, I have noticed that *sometimes*, Kompozer does not pick up the same font for displaying characters like <, > and / in tags in source code mode. Could it be related? I'm attaching a png.

     
  • yukinoroh

    yukinoroh - 2010-03-02

    (and just how do you attach a file?)

     
  • yukinoroh

    yukinoroh - 2010-12-06

    Being discussed in bug #1831943

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks