compilation fails due to ComCtrls.pp

  • carolos

    carolos - 2007-03-14

    Using 2007-02-16 08:31:43Z nightly version of lazarus and free pascal wince crosscompiled
    Using 2007-02-08 SVN of KOL-CE

    Compilation fails on CommCtrls.pp (should it be?)

    (fails on procedure SetWidth(Value: Integer); in TStatusPanel = class(TCollectionItem) with Comctrls.pp(79,55) Fatal: Can't find unit ComponentEditors)

    Tried loading KOL project from delphi
    And tried making project in lazarus
    (same way as you make a KOL MCK project in delphi)
    exactly the same error

    (and WinCE LCL does work)

    any suggestions?


    • jura

      jura - 2007-03-17

      First of all try to compile simple KOL application without using MCK.
      I recommend to use FPC 2.2 beta from svn and the latest version of Lazarus.

      Here is simple KOL hello world application:

      uses KOL;

        Applet:=NewForm(nil, 'Hello from KOL');

      Then try to install MCK package for Lazarus.

    • carolos

      carolos - 2007-03-17

      The simple KOL hello world application seems to work using my FPC 2.1

      I will try latest FPC 2.2 and latest Lazarus and post back my findings.


    • carolos

      carolos - 2007-03-17

      Still using same version of FPC,

      If I change the project to win32 it compiles fine...

      Windows CE obviously doesn't include the unit ComCtrls.pp, should KOL-CE MCK be calling ComCtrls.pp?

    • jura

      jura - 2007-03-17

      Currently there is issue with MCK in Lazarus when compiling project for wince.
      Lazarus tries to recompile MCK package for wince. You need to open MCK package options and turn off automatic rebuild.

    • carolos

      carolos - 2007-03-23

      Worked :)


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks