#702 Images not shown / Kiwix (linux) / Zimwriterfs

v0.9
closed
nobody
None
1
2014-06-25
2014-06-06
No

What I have:
A zimfile generated with the latest libzim and zimwriterfs (git).
Kiwix for linux 0.9-rc2.

What I expect:
After loading the zimfile, kiwix displays the image.

What I get:
A broken image-link icon.

The zim-file does work with kiwix for android. (And of course in a local browser.)

Please see attached sources, zim-file.

Commandline:
zimwriterfs --welcome=html/index.html --language=ger --title=ImgTest --description=ImgTest --creator=Niki --favicon=media/favicon.png --publisher=Niki static/ z.zim

Please let me know, if I can be of any assistance.

3 Attachments

Discussion

  • K.-M. Hansche

    K.-M. Hansche - 2014-06-06

    I bisected the problem and the first bad commit is:
    911f3ae587506238eb079d63a8b1cd3e3e7aca6a

    I think something with the usage of relative paths doesn’t agree with kiwix (linux).

     
  • Emmanuel Engelhart

    Yes, this is related to relative path but with last version of the code, no problem. You shoud also add a <head> tag to your html.

     
  • Nemo

    Nemo - 2014-06-23

    I see the same problem in wikipedia_mg_all_06_2014.zim and wikipedia_it_all_06_2014.zim on 0.9rc2 (Linux e350 3.14.7-200.fc20.x86_64 #1 SMP Wed Jun 11 22:38:05 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux).
    If I try to save an image, the suggested filename looks like this:

    ..../../../../..media/B/l/a/s/Blason_ville_fr_Montrelais(Loire-Atlantique).svg.png

     
  • Nemo

    Nemo - 2014-06-23

    Confirmed fixed in kiwix-20140623_339b3e3f-static-x86_64.tar.bz2

     
  • Emmanuel Engelhart

    • status: open --> closed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks