#2 kionjb requires libid3

closed-fixed
Steup
None
5
2005-02-24
2002-03-23
Anonymous
No

When I run ./configure i et the above error message
even though I installed the required id3lib. As far
as I can tell "libid3" dosen't exsist.

Discussion

  • Nobody/Anonymous

    Logged In: NO

    Got same problem :/
    actual id3lib is installed (CVS)
    other problem:
    need to set $QTLIB manualy to /usr/lib/qt2

     
  • Nobody/Anonymous

    Logged In: NO

    From what I have seen, you have to have id3lib-3.7.13 (at
    least that is what I have). I know that id3lib-3.8.1 will cause
    this issue. I think the resolution should be the developer
    should post the version of id3lib that is needed.

     
  • Nobody/Anonymous

    Logged In: NO

    does not seem to like my qt3.....

     
  • JT Hundley

    JT Hundley - 2004-03-21

    Logged In: YES
    user_id=712163

    And now the older version of id3lib is no longer available
    for download!
    http://sourceforge.net/project/showfiles.php?group_id=979&package_id=974

    I'm trying to hack the configure script to allow it to use
    the newest version of id3lib. If anyone else has gotten it
    to work, please post something for us.

     
  • Anonymous - 2004-03-22

    Logged In: YES
    user_id=1004057

    any info on this yet?
    i'm having the same problem here

     
  • Nobody/Anonymous

    Logged In: NO

    the name of the lib is not libid3 but rather id3lib. and
    yes it does exist. check <a href="http://
    www.id3lib.sourceforge.net" target = "new">this page</a>

     
  • Shaun Jackman

    Shaun Jackman - 2004-06-27

    Logged In: YES
    user_id=274847

     
  • Shaun Jackman

    Shaun Jackman - 2004-06-27
    • assigned_to: nobody --> steup
     
  • Shaun Jackman

    Shaun Jackman - 2004-06-27

    Logged In: YES
    user_id=274847

    The following patch fixes this problem. configure must be
    regenerated after patching configure.in.in.

    --- configure.in.in- 2004-04-26 12:13:05.000000000 -0700
    +++ configure.in.in 2004-04-26 12:07:51.000000000 -0700
    @@ -6,7 +6,9 @@
    AC_MSG_ERROR( [kionjb requires libusb]))
    AC_CHECK_LIB( njb, njb_open,,
    AC_MSG_ERROR( [kionjb requires libnjb]))
    -AC_CHECK_LIB( id3, ID3Tag_New,,
    - AC_MSG_ERROR( [kionjb requires id3lib]), -lz)
    AC_CHECK_LIB( sqlite, sqlite_open,,
    AC_MSG_ERROR( [kionjb requires libsqlite]))
    +
    +AC_LANG(C++)
    +AC_CHECK_LIB( id3, ID3Tag_New,,
    + AC_MSG_ERROR( [kionjb requires id3lib]), -lz)

     
  • Nobody/Anonymous

    Logged In: NO

    I couldnt get that patch to be inserted into my
    configure.in.in, said the hunk failed

     
  • Steup

    Steup - 2004-08-09

    Logged In: YES
    user_id=1047338

    Hi,
    This should be fixed in 0.2.2-st release. Could you please give it a try ?
    Thanks,

     
  • ace jones

    ace jones - 2005-02-24
    • status: open --> closed-fixed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks