KDE 4

kile
2007-04-30
2012-07-03
  • Stefan Majewsky

    Stefan Majewsky - 2007-04-30

    Does Kile already compile with kdelibs 4 and Qt 4, or, (when) is this scheduled?

     
    • Selene007

      Selene007 - 2007-08-15

      Hi dudes!!

      Sorry, What's KD4?
      Where can I get a copy of KD4? Is this a new version of Kile for Windows & MAC?

      Please, explain...

      Thanks in advance!
      Kisses
      Selene

      PD: KILE FOREVER!!!

       
    • Matthias Pospiech

      Is the port to KDE4 available in any open repository?
      WebSVN is only listing up to release 1.9 (http://websvn.kde.org/branches/kile/)

      Matthias Pospiech

       
      • Thomas Braun

        Thomas Braun - 2008-04-11

        Hello Matthias,

        yes. The trunk version in the kde repository can be compiled with KDE4. See http://websvn.kde.org/trunk/extragear/office/kile/ .
        But it is currently not suitable for everyday use.

        Thomas

         
        • ThomasQ

          ThomasQ - 2008-06-16

          Hi Thomas,
          I've tried getting the source from SVN and configuring it, but it seems to be set up for KDE 3. Do you have a configure script (or a means to generate it) for KDE4 around somewhere?

          I'd really like to get Kile running on KDE 4 so that I can run it without the X11 layer on the Mac... The bugs in the Mac X11 layer are really annoying and Kile is the one program that is head and shoulders above any program on the Mac (including Texmaker)!

          cheers,
          Thomas (Q)

           
          • Thomas Braun

            Thomas Braun - 2008-06-16

            Hello,

            the following commands should do the trick:
            - svn co svn://anonsvn.kde.org/home/kde/trunk/extragear/office
            - cd office
            - cmake --prefix=~/.kde .
            - make
            - make install

            Thomas

             
            • Matthias Pospiech

              I tried to compile the version from trunk, but I get this error:

              matthias@localhost:~/Documents/Dev/Linux/kile/office> cmake --prefix=~/.kde .
              CMake Error at /usr/share/cmake/Modules/FindKDE4.cmake:72 (MESSAGE):
              ERROR: cmake/modules/FindKDE4Internal.cmake not found in
              /home/matthias/.kde4/share/apps;/usr/share/kde4/apps;/etc/kde4/share/apps
              Call Stack (most recent call first):
              CMakeLists.txt:3 (find_package)

              This is probably due to a package missing, but I do not know which.

              Matthias

               
              • Thomas Braun

                Thomas Braun - 2008-10-05

                Hi Matthias,

                in debian the package which holds FindKDE4Internal.cmake is kdelibs5-dev.

                Bye,
                Thomas

                 
            • ThomasQ

              ThomasQ - 2008-06-19

              Hi Thomas,
              Thanks for the help - I've been fighting it, and making some progress, but I'm stuck and I hope you (or someone else) can suggest something...

              I'm getting this error when running make (20% through)

              Error: syntax error in /Users/thomasq/Projects/office/kile/src/kile_automoc.cpp.files
              make[2]: [kile/src/kile_automoc.cpp] Error 1
              make[1]:
              [kile/src/CMakeFiles/kile.dir/all] Error 2
              make: *** [all] Error 2

              I've uploaded the file here: http://www.mediafire.com/?wawtdyxm4oz

              Any help would be greatly appreciated.
              thanks,
              thomasq

               
    • Thomas Braun

      Thomas Braun - 2008-06-23

      Hi Thomasq,

      COuld you post a bit more of the error message?

      The file you linked to looks not very familiar to me?
      What system/compiler/kde4 version etc?

      Thanks,
      Thomas

       
    • ThomasQ

      ThomasQ - 2008-06-24

      Hi Thomas,

      I'm using kdelibs, kdesupport and QT from mac.kde.org (KDE 4.1 beta1) on a Macbook running Leopard (10.5.3).

      /opt/qt4/bin/moc -v
      Qt Meta Object Compiler version 59 (Qt 4.4.0)

      The error message (from make):

      [ 18%] Generating mainadaptor.cpp, mainadaptor.h
      [ 19%] Generating mainadaptor.moc
      [ 20%] Generating kile_automoc.cpp
      Error: syntax error in /Users/thomasq/Projects/office/kile/src/kile_automoc.cpp.files
      make[2]: [kile/src/kile_automoc.cpp] Error 1
      make[1]:
      [kile/src/CMakeFiles/kile.dir/all] Error 2
      make: *** [all] Error 2

      Cmake output looks as follows:
      cmake --prefix=~/.kde/ .
      -- Found Qt-Version 4.4.0 (using /opt/qt4/bin/qmake)
      -- Did not find automoc4 (part of kdesupport).
      -- Found KDE 4.1 include dir: /opt/kde4/include
      -- Found KDE 4.1 library dir: /opt/kde4/lib
      -- Found KDE4 kconfig_compiler preprocessor: /opt/kde4/bin/kconfig_compiler
      -- Found KDE4 automoc: /opt/kde4/bin/automoc4
      -- Not building standard documentation
      -- Not building translations
      -- Configuring done
      -- Generating done
      -- Build files have been written to: /Users/thomasq/Projects/office

      I am a bit concerned about the automoc4 not found - Is this the issue?
      Otherwise, my next step is to compile kdelibs and kdesupport from source and see how far I get with this...
      Any other suggestions are appreciated!
      Thanks again for the help.
      thomasq.

       
      • Thomas Braun

        Thomas Braun - 2008-06-24

        Hello thomasq,

        in debian the package is called automoc, it provides the command automoc4 which is needed by the standard kde buildsystem.
        You have installed kdesupport, so that should normally do the trick. Maybe you need to add the path to the automoc4 binary to your $PATH variable. If something like that exists on MacOSX.

        Hope that helps,
        Thomas

         
        • ThomasQ

          ThomasQ - 2008-06-24

          Hi Thomas,
          Funnily enough, it is actually present. BTW Mac OS X is pretty much just like linux (instead of apt-get though, you use fink ;-) )
          Cmake is just not finding it... I even added it explicitly to the $PATH variable

          $ which automoc4
          /opt/kde4/bin//automoc4

          Any suggestions towards forcing cmake to see it?
          cheers,
          thomasq.

           
    • ThomasQ

      ThomasQ - 2008-10-28

      Hi All,
      Just a follow up - I never managed to get Kile running with the KDE 4.1 beta packages but today (finally) have managed with the just released KDE 4.1.2 packages from mac.kde.org. I then downloaded the latest Kile SVN source and it compiled perfectly. One reboot later (no idea why this was needed, but the mac.kde.org message suggested it for all programs) plus running the command:

      launchctl load -F /Library/LaunchAgents/org.freedesktop.dbus-session.plist

      to get dbus running and I now have a running version of Kile without X11 on the Mac ;-)

      Thanks for all the help and if anyone needs help compiling it check out:
      http://techbase.kde.org/Projects/KDE_on_Mac_OS_X/Macbook_Manifesto

      Follow those steps and it should work. Next job: Figure out how mac packages are built and I'll throw up the compiled program somewhere...
      cheers,
      thomasq

       
      • Thomas Braun

        Thomas Braun - 2008-10-28

        Hi thomasq,

        thanks for the hints. Would be nice if you could try to update the file "README.MacOSX" which resides in the top level kile directory. It was written for KDE 3.x.

        Bye,
        thomas

         
        • ThomasQ

          ThomasQ - 2008-10-28

          Hi Thomas,
          I've done this and sent it to the kile-devel list. Also, if anyone is interested you can get the compile version as a package from: http://www.skynet.ie/~tom/projects/files/Kile.pkg.zip

          regards,
          thomasq.

           
        • Thomas Braun

          Thomas Braun - 2008-11-04

          I just commited your changes.

          Thanks.

           
    • Hakan

      Hakan - 2008-11-10

      Hi thomasq,
      I have just installed the compiled version of kile with kde 4 for macosX that you submitted to the kile-devel list. I should thank you for this great service, as otherwise I would have just kept postponing to compile from the source knowing what lies ahead from my previous experience.

      Just a quick question to start working on it as I used to with the old version:
      In the old X11 version of kile (on tiger), I had several features specifically for latex that seems to have disappeared (like auto-completion of latex commands, on the fly compiling+pdf generation etc). I have checked the preferences but I don't see any option to tweak for getting back these features. Can you (or anyone else) give me a pointer on how to fix this?

      Kind regards,
      Hakan

       
    • Michel Ludwig

      Michel Ludwig - 2007-05-01

      No, the porting is scheduled to be done immediately after the 2.0 release, i.e. Kile 2.0 is going to be the last release for the KDE 3.x series.

      Michel

       
      • Squirrel

        Squirrel - 2008-03-22

        Hi

        What's the status for the KDE4 portation?

         
    • Matthias Pospiech

      Is there any timeschedule for the next release?
      Kile 2.0 sound like it introduces main differences to prior Versions. Is there any preview available?

      Looking forward to Kile 2.x with KDE4, especially looking forward for Kile on Windows to make Kile the most used editor on every platform. It is so much better than Texniccenter, which is the only know TeX Editor to most people I work with.

      Matthias

       
  • tom sobey

    tom sobey - 2009-10-04

    Hi thomasq and others,

    i have kile running successfully on kde4 on mac os leopard(without X11). I
    would like it to use the texlive distribution rather than tetex distribution,
    is there a way I can tell it where to find this, without defining for every
    single build/view comand under configure kile?

    thanks very much!

    tom

    tsobey@hotmail.com

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks