Kile Autocomplete stopped working

  • Dominic

    Dominic - 2011-02-17


    I find Kile incredibly useful and one of my favourite features is the

    However, around two weeks ago it stopped working completely for latex

    The side-bar still contains all the latex commands, but as I type them really
    slowly (or even at any speed) I never get the dropdown menu with the
    autocomplete options.

    I am fairly certain I didn't change anything in these last few weeks, and I
    have checked and rechecked the settings (and tried as many combinations I can
    think of) to get it to work, but it still doesn't.

    I do have the dictionary files for the latex commands.

    I would really like this feature back, is there anything I can try?

    I have already done an apt-get purge and apt-get install on kile to try to
    clear the problem.

    Thank you for any suggestions you may have.

  • Michel Ludwig

    Michel Ludwig - 2011-02-17

    If you want to run Kile again KDE SC 4.6 with auto completion, you'll have to
    compile Kile 2.1 beta 5 against KDE SC 4.5 or 4.6. As it seems that your
    distribution doesn't provide such packages yet, you can still compile Kile
    yourself. You can find instructions for doing so here:

  • philiphilli

    philiphilli - 2011-05-03


    I report the same problem:

    in both fedora 14 (kile 2.1 b5) and ubuntu 4.11 (kile 2.1 b4):

    autocomplete of latex commands and normal text only (sometimes) works only if
    the first letter is omitted, the three (or more) adjacent letters are written,
    one then scrolls back to the position of the first letter and types this one.

    This can't be right, right? If there is a way to fix it, could you (whoever
    knows how to do this) please explain how to sort it out in step-by-step
    instructions? Because I couldn't follow mludwig2's instructions successfully I
    am afraid. Sorry.

    Thanks for your help in advance. Ph.

  • Anonymous - 2011-09-12

    Same problem here. Was using Ubuntu 10.10 on my old computer, one day
    autocomplete for latex commands stopped working in Kile. Installed Ubuntu
    11.04 fresh on a new computer, autocomplete not working at all. The trick with
    typing the second and third letter and then going back and entering the first
    letter only turns autocomplete for previously used words on, not for latex


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks