Help: /.config can't find the X files

kile
Diego Ruiz
2005-04-06
2012-07-03
  • Diego Ruiz

    Diego Ruiz - 2005-04-06

    Hi all!

    I've tried to upgrade from Kile 1.6 to 1.7 and found the following problem:

    When running /.config I get an error message indicating that config is unable to finding the X files and, consequently, the installation can not be finished.

    As long as I'm upgrading, I'm sure that the X files are available: How can I indicate the location off the X files to "congig"?

    Does anyone have a hint?
    Thanks,
    Diego

     
    • Jeroen Wijnhout

      Jeroen Wijnhout - 2005-04-07

      Did you compile 1.6 from source as well?

      Anyway, you could use the
      --with-extra-includes=DIR
      switch to pass to configure:
      ./configure --with-extra-includes=/path/to/Xheaders

      best,
      Jeroen

       
    • Diego Ruiz

      Diego Ruiz - 2005-04-07

      As long I can remember I used a rpm for 1.6. But I can be sure about that. Thank you, I'll try with the switch.
      Best,
      Diego

       
      • Jeroen Wijnhout

        Jeroen Wijnhout - 2005-04-07

        Installing using an RPM is not the same as compiling Kile from source. If you compile from source you need to have the x-devel, qt-devel and kde-devel packages installed. Otherwise you can't compile any KDE application, including Kile. So install those package first (you probably do not need the configure switch then).

        best,
        Jeroen

         

Log in to post a comment.