Patch against 1.0.2