Kiax in Suse 10.0 failed

Help
KMA
2006-01-16
2013-04-25
  • KMA

    KMA - 2006-01-16

    Hi all,
    I'm trying to install the rpm for Suse 10.0 and got this error:
    # rpm -ivh kiax-0.8.4-1.SuSE.src.rpm
       1:kiax                   warning: user velislav does not exist - using root
    ########################################### [100%]
    warning: user velislav does not exist - using root

    I can't find the command to use Kiax. Where do I look to see if the rpm installed correctly?

    Thanks,
    KMA

     
    • Emo

      Emo - 2006-01-18

      it seems the source rpm package is built with wrong rights. Try the binary package. If you want to build from source try the tar.bz2 archive.

      Greetings,
      Emo

       
    • KMA

      KMA - 2006-01-18

      I got the tar.bz2 archive and extracted it. I then ran ./configure and it didn't show anything response. This is what I received when running make:
      KMA:/tmp/kiax-0.8.4 # make
      cd lib && make
      make[1]: Entering directory `/tmp/kiax-0.8.4/lib'
      cc -I. -Igsm/inc -Iportaudio/pa_common -Iportaudio/pablio -Iportmixer/px_common -Ilibspeex/include -g -O2  -DLIBVER='"CVS-2006/01/18-12:38"' -DSPEEX_PREPROCESS=1 -DNEWJB -DCODEC_ILBC -Ilibiax2/src -DLIBIAX  -DSPEEX_EC=1 -DLINUX   -c -o iaxclient_lib.o iaxclient_lib.c
      iaxclient_lib.c:52: error: static declaration of ‘iaxc_lock’ follows non-static declaration
      iaxclient_lib.h:203: error: previous declaration of ‘iaxc_lock’ was here
      iaxclient_lib.c:85: error: static declaration of ‘iaxc_event_callback’ follows non-static declaration
      iaxclient_lib.h:202: error: previous declaration of ‘iaxc_event_callback’ was here
      iaxclient_lib.c: In function ‘iaxc_post_event’:
      iaxclient_lib.c:187: warning: incompatible implicit declaration of built-in function ‘memcpy’
      iaxclient_lib.c: In function ‘iaxc_do_state_callback’:
      iaxclient_lib.c:250: warning: incompatible implicit declaration of built-in function ‘strncpy’
      iaxclient_lib.c: In function ‘iaxc_initialize’:
      iaxclient_lib.c:402: warning: incompatible implicit declaration of built-in function ‘strncpy’
      iaxclient_lib.c: In function ‘iaxc_set_callerid’:
      iaxclient_lib.c:456: warning: incompatible implicit declaration of built-in function ‘strncpy’
      iaxclient_lib.c: In function ‘handle_text_event’:
      iaxclient_lib.c:676: warning: incompatible implicit declaration of built-in function ‘strncpy’
      iaxclient_lib.c:676: warning: pointer targets in passing argument 2 of ‘strncpy’ differ in signedness
      iaxclient_lib.c: In function ‘handle_url_event’:
      iaxclient_lib.c:688: warning: incompatible implicit declaration of built-in function ‘strcpy’
      iaxclient_lib.c:698: warning: incompatible implicit declaration of built-in function ‘strncpy’
      iaxclient_lib.c:698: warning: pointer targets in passing argument 2 of ‘strncpy’ differ in signedness
      iaxclient_lib.c: In function ‘iaxc_register’:
      iaxclient_lib.c:865: warning: incompatible implicit declaration of built-in function ‘strncpy’
      iaxclient_lib.c: In function ‘iaxc_call’:
      iaxclient_lib.c:884: warning: incompatible implicit declaration of built-in function ‘strstr’
      iaxclient_lib.c:918: warning: incompatible implicit declaration of built-in function ‘strncpy’
      iaxclient_lib.c:921: warning: incompatible implicit declaration of built-in function ‘strncpy’
      iaxclient_lib.c:925: warning: incompatible implicit declaration of built-in function ‘strncpy’
      iaxclient_lib.c: In function ‘iaxc_service_network’:
      iaxclient_lib.c:1134: warning: incompatible implicit declaration of built-in function ‘strncpy’
      iaxclient_lib.c: In function ‘iaxc_version’:
      iaxclient_lib.c:1257: warning: incompatible implicit declaration of built-in function ‘strncpy’
      make[1]: *** [iaxclient_lib.o] Error 1
      make[1]: Leaving directory `/tmp/kiax-0.8.4/lib'
      make: *** [sub-lib-make_default] Error 2
      KMA:/tmp/kiax-0.8.4 #    

      I don't know what could be wrong. any ideas what to do? 

      Thanks,

      KMA                                    

       
    • Emo

      Emo - 2006-01-23

      ok, it seems suse10 has gcc4 installed..I know there are problems with it but never tested it with gcc4 (i myself stick yet to gcc3). do you have the ability to use gcc3 in suse10?

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks