portaudio error

  • Christophe PEREZ


    I'm creating a liveCD (gentoo based) and I'd like to put kiax inside.
    But, I always have an error :

    novazur@livecd ~ $ kiax
    lun avr 17 22:51:27 2006 Using IAXClient ver. CVS-2006/04/17-10:00
    PortAudio error at Unable to open streams: illegal error number.
    lun avr 17 22:51:27 2006 IaxWrapper::iaxc_initialize() result = 0
    Erreur de segmentation

    I can see that I'm not the only one :

    But, I have no problem with kiax on all my fixed install (5 PCs), only with this liveCD.

    Someone can try to help me please ?

    • Lund

      Lund - 2007-01-26

      I am having the excact same problem in Back Track 2 beta (Slackware 10.2 based) did you ever find a solution to this problem ? If so, please let me know.

      • Marcin Zajaczkowski

        That's not a solution, but I have similar error (Unable to open streams) on my laptop when try to start kiax (iaxclient) when another "sound application" is already run (like Rhythmbox). I don't see that problem on my desktop PC with SB Live.

        Maybe there is started "sound server" or other deamon application which uses sound card?


        • Emo

          Emo - 2007-01-28

          The version of Iaxclient/Portaudio that is the current version of Kiax uses OSS. It seems like you don't have OSS emulation support in your ALSA, take a look at kernel conf to enable the OSS emulation.


    • Lund

      Lund - 2007-01-27

      i don't think so, i've closed down all the apps that might access the sound device , even the volume control. but i still get the same error. i forgot to mention that i am running a HD install of BT2 and not a live CD if that matters.

    • Lund

      Lund - 2007-01-28

      Hey, Emil, I did not see your post until now. How do I go about editing my kernel config ? This is fairly new to me as I have not had any use for it as of today.


      • Emo

        Emo - 2007-01-29


        Usually you have to load OSS emulation modules if your linux distro scripts are not doing it for you.
        Check this address for more info on module loading:


        and the next link to see if your drivers are loaded:



        • jim

          jim - 2008-02-16

          Has this problem been solved? I have it also:

          PortAudio error at Unable to open streams: Illegal error number.

          But i have the oss alsa emulation modules loaded:

          [root@localhost ~]# lsmod | grep oss
          snd_seq_oss            32577  0
          snd_seq_midi_event     11073  1 snd_seq_oss
          snd_seq                49713  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
          snd_seq_device         11725  3 snd_seq_dummy,snd_seq_oss,snd_seq
          snd_pcm_oss            42945  0
          snd_mixer_oss          19009  1 snd_pcm_oss
          snd_pcm                72133  4 snd_hda_intel,snd_hda_codec,snd_pcm_oss
          snd                    52421  13 snd_hda_intel,snd_hda_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer

          kiax seems to crash from a non-UI thread:

          Program received signal SIGSEGV, Segmentation fault.
          [Switching to Thread -1212355696 (LWP 8968)]
          0x00000000 in ?? ()
          (gdb) info thread
            4 Thread -1233335408 (LWP 8970)  0x00552402 in __kernel_vsyscall ()
            3 Thread -1222845552 (LWP 8969)  0x00552402 in __kernel_vsyscall ()
          * 2 Thread -1212355696 (LWP 8968)  0x00000000 in ?? ()
            1 Thread -1209046528 (LWP 8967)  0x00b267e0 in __umoddi3 () from /lib/libgcc_s.so.1
          (gdb) backtrace
          #0  0x00000000 in ?? ()
          #1  0x080a76fb in iaxc_process_calls () at iaxclient_lib.c:666
          #2  0x080a7b35 in iaxc_processor (args=0x0) at iaxclient_lib.c:565
          #3  0x0012545b in start_thread () from /lib/libpthread.so.0
          #4  0x0022c24e in clone () from /lib/libc.so.6

          Anyone know how to fix this?

          • Emo

            Emo - 2008-02-19


            Portaudio issues are related to the old snapshot of PortAudio v18 which has been used by libiaxclient which on its turn is used by Kiax. The new version of libiaxclient depends on the v19 version of PortAudio which supports ALSA so this kind of issues will not be a problem. However Kiax project experiences major transformation right now - complete rewrite with QT4 + abstraction layer for signaling and persistence. Once we reach a usable milestone the sourceforge SVN and the homeapge will be updated accordingly.



Log in to post a comment.