Qt User Interface Compiler version problem

2007-05-05
2013-04-25
  • janos_master

    janos_master - 2007-05-05

    Hi guys,
            I'm trying to do some changes in the Kiax Code, But I'm unable to compile. I have some UIC version problems:

    /usr/bin/qmake -unix -o Makefile src.pro
    uic: File generated with too old version of Qt Designer
    uic: File generated with too old version of Qt Designer
    uic: File generated with too old version of Qt Designer
    uic: File generated with too old version of Qt Designer
    uic: File generated with too old version of Qt Designer
    uic: File generated with too old version of Qt Designer
    uic: File generated with too old version of Qt Designer
    make[1]: Leaving directory `/usr/src/kiax-0.8.51-src/src'
    make[1]: Entering directory `/usr/src/kiax-0.8.51-src/src'
    /usr/bin/uic-qt4 logwindow.ui -o ui_logwindow.h
    uic: File generated with too old version of Qt Designer
    File 'logwindow.ui' is not valid
    make[1]: *** [ui_logwindow.h] Error 1

    I installed qdevelop 0.22 and $ uic -version
    Qt User Interface Compiler version 4.2.3

    Please, help me.

    Thanks!

     
    • Emo

      Emo - 2007-05-05

      Hi,

      You are using qt4 ui compiler, while kiax ui was generated with qt3 designer. Undortunately, compatibility between these two major versions of QT is completely broken. If you are aiming modifications on linux, install qt3 and its designer - it should work. You have to adjust QTDIR envrionment accordingly in order not to mix both versions.

      Greetings,
      Emil

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks