#19 Segmentation Fault on Ubuntu

closed
nobody
None
5
2008-05-29
2006-11-09
Anonymous
No

X Error: BadDevice, invalid or uninitialized input
device 168
Major opcode: 145
Minor opcode: 3
Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input
device 168
Major opcode: 145
Minor opcode: 3
Resource id: 0x0
Failed to open device
Thu Nov 9 10:14:44 2006 Using IAXClient ver.
CVS-2006/06/08-00:37
PortAudio error at Unable to open streams: Illegal
error number.
Thu Nov 9 10:14:44 2006 IaxWrapper::iaxc_initialize()
result = 0
Segmentation fault (core dumped)

Running on Ubuntu 6.10
Linux jonta-desktop 2.6.17-10-generic #2 SMP Fri Oct 13
18:45:35 UTC 2006 i686 GNU/Linux

Discussion

  • David Cornewell

    David Cornewell - 2007-01-09

    Logged In: YES
    user_id=765158
    Originator: NO

    I also get a seg fault. FC5. linux 2.6.18-1.

    #kiax
    Mon Jan 8 23:09:55 2007 Using IAXClient ver. CVS-2006/03/27-23:45
    PortAudio error at Unable to open streams: Illegal error number.
    Mon Jan 8 23:09:56 2007 IaxWrapper::iaxc_initialize() result = 0
    Segmentation fault

    if I give it a param, no seg but nothing comes up either.

    #kiax -h
    Mon Jan 8 23:09:55 2007 Using IAXClient ver. CVS-2006/03/27-23:45
    PortAudio error at Unable to open streams: Illegal error number.
    Mon Jan 8 23:09:56 2007 IaxWrapper::iaxc_initialize() result = 0

     
  • Emo

    Emo - 2007-01-26

    Logged In: YES
    user_id=1223718
    Originator: NO

    It looks like we are having problems with USB devices. Can you confirm you have USB attached microphones or web cameras?

     
  • Nobody/Anonymous

    Logged In: NO

    I did not have anything plugged in to the usb. I was on an Acer C100 tablet pc. The only thing that may be on USB is the touchscreen driver. It is embeded, but I believe I needed USB support in the kernel for it to work.

    If you want me to test anything, I can. I haven't messed with this since I posted the comment.

     
  • Emo

    Emo - 2007-01-28

    Logged In: YES
    user_id=1223718
    Originator: NO

    It would be great if we narrow the source of problem with trying another iaxclient-based app. Do you have similar behavior with IaxComm? From the logs it is clear that PortAudio (The audio layer of iaxclient) has difficulties with opening any devices, or at least the device by default (0).
    Thanks,

    Emil

     
  • S4mdf0o1

    S4mdf0o1 - 2007-09-26

    Logged In: YES
    user_id=1899193
    Originator: NO

    This app is using liboss (seen in the code)
    Just start it with
    $ aoss kiax

    For a KDE app, it should use artsd ...

     
  • Emo

    Emo - 2008-05-29
    • status: open --> closed
     
  • Emo

    Emo - 2008-05-29

    Logged In: YES
    user_id=1223718
    Originator: NO

    I am closing this ticket for Kiax 0.8.x is no longer supported in favor of Kiax ver 2 - a re-write of the softphone with QT 4.x. Pls take a look at sf.net/projects/kiax for more information and downloads.
    Best regards,
    Emil

     

Log in to post a comment.