Error while taking screenshot

Help
Hans-ola
2008-10-06
2012-12-15
  • Hans-ola

    Hans-ola - 2008-10-06

    Hello

    I have i Ubuntu 7.10 server environment where i need to take screenshot of around 1000 webpages a week.

    I installed all required pakages including KDE that was said on khtmltopng's website.

    I'm not a linux expert so I might have done somthing wrong. btw my server is a virtual mashine in a windows VMWare session(shouldn't make different but giving you all info).

    When i try take a screenshot with "./khtml2png2 url http://www.google.se outfile google"

    I get a couple of error

    1) I Khtml2png2 windows pops up saying "An error occoured while loading url:
    Could not start process Unable to create io-slave:
    Klauncher said: Unknown protocol"

    2) A popup dialogbox saying pretty much the same thing as above

    3) The consoles spits out 3 error massages all saying "OIImageIO: write: No such image format handler: SE"

    I thought about image format and tryed google.png, google.jpg aswell as only google as outfileparameter.

    Any ides, as I said i'm a newbie to linux and it could be something i'v done wrong with the install of all pakages needed.

    I be glad for help I can get.

    Tnx in advance!

    /Marcus

     
    • Florent Bruneau

      Florent Bruneau - 2008-10-06

      Hi Marcus,

      You're command line is wrong. You don't have to specify "url" and "outfile", but you have to add an extension to the outfile.

      You should try something a command line like:
      ./khtml2png2 http://www.google.se google.png

      Greetings,
      Florent

       
    • Hans-ola

      Hans-ola - 2008-10-08

      Now it works as it should.

      Thanks a lot Florent, you saved my day :P

      /Marcus

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks