"Parameter is Incorrect"

Anonymous
2013-07-05
2013-10-15
  • Anonymous - 2013-07-05

    Originally posted on "general discussion" but probably best under "Developers Forum".

    I keep getting error "Parameter is Incorrect" when accessing the video menu. The screenshot shown explains this more clearly. My system is Win7 32bit...with all software up to date.

    https://dl.dropboxusercontent.com/u/51137860/Khan%20Desktop%20Error.jpg

    I'm not sure if this program has been tested on Win7 or if there's another Sourceforge program superseding it?

     
  • Gary

    Gary - 2013-07-05

    It has been tested on win7.

    You are streaming the vid from the khan server, and will need to be connected to the internet - the program would warn you however if you were not connected.

    Can you right click on the video, select download, then download it from the download tab, and then play it?

    I'll load win7 and check it out. It does steam in my XP.

    Update: There is also a chance that updating the contents could fix it if the url to that video has changed. Can you try updating from the update tab (a 16 mb download) and see if that fixes?

    Update: Your screen shot shows something strange. A video is selected (Empires before ww1), but the right pane shows the description for the "Beginning of WW1" Topic. That should not happen.

    Thanks,
    Gary

     
    Last edit: Gary 2013-07-05
    • Wolfraven004

      Wolfraven004 - 2013-10-15

      I would love to test this for you I have virtual machines that run all OS's please send me link to download.wolfraven004@gmail.com.I also run windows 8.I study programming and a+ certified.

       
      • Gary

        Gary - 2013-10-15

        Thanks - you can download KhanSetup_0.9.2.zip from the Summary or Files page. It's for Windows XP or later.

         
  • Gary

    Gary - 2013-07-05

    I am unable to duplicate this on Win7 or xp. All works perfectly.

    What is not perfect is how you are getting a video selected and not having the video description displayed in the right pane. You have found some keyboard or mouse click sequence which is a bug.
    So when you pess the play button the program tries to play a topic, not a video (I think).

    Can you please try to duplicate this and let me know which keys and mouse clicks are needed to reproduce the screen shot?

    Here is a screen shot of what it should look like before you press the play button or right click and select Play From Khan Server:

    https://dl.dropboxusercontent.com/u/13390614/kdbug.jpg

    Thanks
    Gary

     
  • Anonymous - 2013-07-06

    Thanks for looking into it gary. For the following screen shot I did the following:

    • Opened Khan Desktop
    • Clicked Math
    • Clicked Addition & Subtraction
    • Clicked Intro to addition and subtraction
    • and then go the "Parameter is Incorrect" Error.

    I've attached a file of the screen capture.

    If I click OK multiple times I eventually get to the video screen, but it does not play.

    I've tried it in various "Compatibility modes" (back to Win2000, WinXP), and on my two different computers. I definitely have an Internet connection. I hit setup and update application and was told I had the latest version. I went to the update TAB and downloaded the latest update (it downloaded for a few minutes). I then repeated the sequence and got the same error again.

     
  • Anonymous - 2013-07-06

    I should add that if I click "OK" I will again get parameter is incorrect for each separate final heading of the "tree" - so I just click "Ok" "Ok" "Ok" until I can see them all. I then attempt to play the video but it does not work. Given that the program DID update, the program does see an Internet connection.

     
  • Anonymous - 2013-07-06

    I cannot RIGHT click on the video and then download it - in this case I get MULTIPLE "parameter is not correct" errors.

    Finally...I tried to reproduce your image...attached...you can see that it will give a "Parameter is Incorrect" error for EACH video in the tree - so I have to click multiple times until it produces the whole. In fact, even if I try and MOVE the window pane, I have to go right through the process again and do an "OK" for "Parameter is Incorrect" for as many final links in the tree that happen to be open. I hope this all helps...

     
  • Gary

    Gary - 2013-07-06

    Thanks for hanging in there, and sorry for the problems.

    The compatibility modes are not needed. You should clear all the compatibility check boxes.

    Ensure you have version 0.9.1.0. The help/about menu will show this.

    It never hurts to uninstall, get a new download from source forge, and reinstall.

    If you get an error message, continuing to click won't help.

    Something is happening with the mouse.

    Start Khan Desktop, click on any topic ONCE, then use ONLY the arrow keys to navigate through the tree.

    If no errors occur, navigate to a video, then click on the PLAY button. It should stream the video or inform that you are offline.

    Let me know if that works. I will try to duplicate the problem here.

    Gary

     
    Last edit: Gary 2013-07-06
  • Anonymous - 2013-07-07

    Yes - version 0.9.1.0.
    I used mouse to click TOPIC, then ARROW KEYS only to navigate.
    Same problem.
    I've downloaded from Sourceforge twice - same problem.

    I'm hanging in there as it does look like a great piece of software!

     
  • Anonymous - 2013-07-07

    Mind you, like before, it ONLY happens when I get down to the last branch in the tree - I can open up all the other menu levels - it simply doesn't like it when we actually get to the video pane.

     
  • Gary

    Gary - 2013-07-07

    Bummer. The program is not written with sufficent error reporting code for me to crack this.

    Are you using english language computers?

    Are you using any sort of virtual box setup - multiple operating systems?

    Suggestions from the SF crowd are welcome.

    I'll keep checking around for possible causes.

    Gary

     
  • Anonymous - 2013-07-07

    English-language (in Sydney)
    No virtual box.
    Wire to Home - then Ethernet connections to various computer.
    Installed on a stand-alone (newish) Toshiba Laptop with Win7 64bit.
    Exactly the same errors.
    Disabled Antivirus (Avast) and anything else that might mess it up.

    I have had some past problems with the installation of Java; but these seemed
    resolved. What is "Khan Desktop" actually written in?

     
  • Anonymous - 2013-07-07

    I assume as the VLC media player is built-in, that my normal installation of VLC is irrelevant.

     
  • Anonymous - 2013-07-07

    Actually, the whole thing does actually work once I get to the video - video plays, and I can hear sound - but I've got to hit "OK" about 50 times to get there - same deal whenever I move the window. Very odd. It may perhaps be something to do with Win7 or a Driver but I don't really know - it's such a non-descript error.

     
  • Anonymous - 2013-07-07

    As you can see I CAN actually play the videos - but every time I click on another video I will need to click "OK" for another 10 times before I can bring up the next video - so not usable

     
  • Anonymous - 2013-07-07

    Ooops...that didn't show up well on the screen capture - take it from me I can video playing there...Bill Gates talking about Super Sal... ;-)

     
  • Gary

    Gary - 2013-07-07

    Your VLC is fine, KD (Khan Desktop) uses its own VLC DLLs.
    No JAVA, all win32 and MFC code, 32 bit.
    No dot net, except for the Windows Installer.

    When a video gets selected, information is gathered about it and displayed in the right pane, as my screen shot above shows.

    The bug is in that code, probably a conversion from 64 to 32 bit numeric or string data.

    The keyboard AND mouse are involved, so it could be a driver for both such as a wireless device.

    No matter what, KD should be able to deal with it, or at least do proper error handling/reporting.

    I'll try to find time for an update.

    There may be usefull info in your System Error logs. One click on a video will create one log entry which might point out the problem. If you find something, do post it.

    Thanks for all you time,

    Gary

     
  • Anonymous - 2013-07-08

    will do...and will see what i can find...

    thanks gary...i admire the work you guys do to make such a valuable resource more available...

     
  • Anonymous - 2013-07-08

    Error in Event Log..not sure it helps...find Khan.exe doesn't start sometimes as well, after it's crashed...

    Faulting application name: Khan.exe, version: 0.9.1.0, time stamp: 0x51796e7e
    Faulting module name: Khan.exe, version: 0.9.1.0, time stamp: 0x51796e7e
    Exception code: 0xc0000409
    Fault offset: 0x00029472
    Faulting process id: 0x1f08
    Faulting application start time: 0x01ce7ab84a28a601
    Faulting application path: C:\Program Files\Khan Desktop\Khan Desktop\Khan.exe
    Faulting module path: C:\Program Files\Khan Desktop\Khan Desktop\Khan.exe
    Report Id: 87da49ad-e6ab-11e2-b72d-7071bc8fc1fc

     
  • Anonymous - 2013-07-08

    On another computer I got the same error (this same error repeated MANY MANY TIMES):

    Faulting application name: Khan.exe, version: 0.9.1.0, time stamp: 0x51796e7e
    Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
    Exception code: 0xc0000096
    Fault offset: 0x003f6c69
    Faulting process id: 0x1648
    Faulting application start time: 0x01ce7afe0882462a
    Faulting application path: C:\Program Files\Khan Desktop\Khan.exe
    Faulting module path: unknown
    Report Id: 463cc397-e6f1-11e2-abf4-00270e0a916c

    Once I did get this error (which didn't really make sense as it was on a local drive):

    Faulting application name: Khan.exe, version: 0.9.1.0, time stamp: 0x51796e7e
    Faulting module name: Khan.exe, version: 0.9.1.0, time stamp: 0x51796e7e
    Exception code: 0xc0000409
    Fault offset: 0x00029472
    Faulting process id: 0x36c
    Faulting application start time: 0x01ce7b9d49f6db9b
    Faulting application path: C:\Program Files\Khan Desktop\Khan Desktop\Khan.exe
    Faulting module path: C:\Program Files\Khan Desktop\Khan Desktop\Khan.exe
    Report Id: 87a9b7cb-e790-11e2-96f4-7071bc8fc1fc

    Windows cannot access the file for one of the following reasons: there is a problem with the network connection, the disk that the file is stored on, or the storage drivers installed on this computer; or the disk is missing. Windows closed the program Khan Desktop Application because of this error.

    Program: Khan Desktop Application
    File:

    The error value is listed in the Additional Data section.
    User Action
    1. Open the file again. This situation might be a temporary problem that corrects itself when the program runs again.
    2. If the file still cannot be accessed and
    - It is on the network, your network administrator should verify that there is not a problem with the network and that the server can be contacted.
    - It is on a removable disk, for example, a floppy disk or CD-ROM, verify that the disk is fully inserted into the computer.
    3. Check and repair the file system by running CHKDSK. To run CHKDSK, click Start, click Run, type CMD, and then click OK. At the command prompt, type CHKDSK /F, and then press ENTER.
    4. If the problem persists, restore the file from a backup copy.
    5. Determine whether other files on the same disk can be opened. If not, the disk might be damaged. If it is a hard disk, contact your administrator or computer hardware vendor for further assistance.

    Additional Data
    Error value: 00000000
    Disk type: 0

    I can't see any other error files that are relevant, although this one did pop up...

    ====================================================================================

    • System

    • Provider

    [ Name] Application Error

    • EventID 1000

    [ Qualifiers] 0

    Level 2

    Task 100

    Keywords 0x80000000000000

    • TimeCreated

    [ SystemTime] 2013-07-08T02:12:37.000000000Z

    EventRecordID 40122

    Channel Application

    Computer Kenney-Server

    Security

    • EventData

    AUDIODG.EXE
    6.1.7601.17514
    4ce7a278
    MMDevAPI.DLL
    6.1.7601.17514
    4ce7b892
    c0000005
    00018d99
    2284
    01ce7b1578851ec3
    C:\Windows\system32\AUDIODG.EXE
    C:\Windows\System32\MMDevAPI.DLL
    db4a094f-e773-11e2-b72d-7071bc8fc1fc

    ====================================================================================

    That's all I could find...any help?

     
  • Gary

    Gary - 2013-07-10

    Good job - very helpfull. I'll work on it this weekend.

    Gary

     
  • Anonymous - 2013-07-11

    Thanks Gary!

     
  • Gary

    Gary - 2013-08-10

    I have released an update which may fix this, and if not, will provide the needed data to do so.

    It is located in the Files, SourceCode, Test folder of this web site.

    There is an info0911.txt there which explains the release.

    If possible, I would like to ensure this is fixed before releasing it as a regular update.

    Let me know what you think.

    Gary

    Update:
    Fixes are now included in the 0.9.2.0 release.

     
    Last edit: Gary 2013-08-19


Anonymous

Cancel  Add attachments