Any luck with Logitech diNovo mini?

Help
Morten
2009-03-10
2013-04-17
  • Morten

    Morten - 2009-03-10

    Hi.
    Did anyone succeed getting a diNovo mini to work?
    It's connected via an USB bluetooth receiver, and it's ordinary keyboard works out of box, but the majority of the multimedia controls don't.

    I run mythbuntu and installed keytouch 2.3 and the keytouch-editor. When I run the editor, it comes up and asks me to select a device. I see two 'Logitech Logitech BT Mini-Receiver' devices, but none of them respond to any keypresses - not even on the normal keyboard-buttons, so I am kind of stuck there.

    Should I go through the manual compile to get the latest keytouch up and running, or is it a dead end?

    Thanks,
    /Morten

     
    • Marvin Raaijmakers

      You should use keyTouch 2.4 in combination with the latest version (the beta) of keyTouch-editor.

      - Marvin

       
    • Morten

      Morten - 2009-03-10

      That's a quick answer!

      I can build keytouch-2.4.1 with no problems, but when I try building keytouch-editor-3.2.0-beta, I get a compile error as someone else described in https://sourceforge.net/tracker/index.php?func=detail&aid=2043362&group_id=111201&atid=658553

      /Morten

       
    • Morten

      Morten - 2009-03-12

      Now I tried to avoid the non-compiling keytouch-editor program and follow the guide in
      http://prdownloads.sourceforge.net/keytouch/howto_keyboard_2.1.pdf?download
      and for the volume down buttong, I got the following keycode with 'getscancodes' (that compiled fine):
      786666 (0xC00ea)

      So I crafted the following 'I-want-one-key-working-first' xml-file and got it imported in keytouch:

      <keyboard>
        <file-info>
          <syntax-version>1.1</syntax-version>
          <last-change format="%d-%m-%Y">10-03-2009</last-change>
          <author>Morten Breum Mikkelsen</author>
        </file-info>

        <keyboard-info>
          <keyboard-name>
            <manufacturer>Logitech</manufacturer>
            <model>diNovo mini (USB bt) Y-RBG93</model>
          </keyboard-name>
        </keyboard-info>

        <key-list>
          <key>
            <name>Volume Down</name>
            <scancode>786666</scancode>
            <keycode>VOLUMEDOWN</keycode>
            <default-action action-type="program">
              mythfrontend
            </default-action>
          </key>
        </key-list>
      </keyboard>

      But for some reason, mythfrontend does not show up when I press the button. I also tried reconfiguring the command to something else just in case, but no action seems to be performed.

      What do I do to debug that?

      Thanks,
      /Morten

      PS. Perhaps I missed it, but I didn't seem to read anywhere that getscancodes will not work in a terminal within an X environment, but I found out that I had to go to a non-graphical console to receive anything.

      PPS. Importing a keyboard in keytouch requires root privileges (got a permission denied when the GUI tried to copy the xml file from my home directory). I moved the file by hand and got in a fight with the naming convention, but I got it sorted out.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks