Synology SFTP with KeePassSync Setup?

Vaako
2013-03-12
2013-03-13
  • Vaako

    Vaako - 2013-03-12

    Hi,

    I have enable Synology SFTP server and like to use KeePassSync to store a backup there.
    But I can not get it to work and need some help with it.

    Settings in Synology are:
    Enable SFTP
    Host: IP address of the SFTP
    Port: 22
    Username: *
    Password: *

    What is "use peagent instead" ?
    Directory: /volume1/documents
    C:\Program Files (x86)\KeePass Password Safe 2\ PLINK path: C:\Program Files (x86)\KeePass Password Safe 2\ Keepas Root did not work for me!
    Timeout seconds: 7

    If I click SYNC I get an popup with prompt and this message:
    Looking up host "192.168.1.200"
    Connecting to 192.168.1.200 port 22
    Server version: SSH-2.0-OpenSSH_5.8p1-hpn13v11
    We claim version: SSH-2.0-PuTTY_Release_0.60
    Using SSH protocol version 2
    Doing Diffie-Hellman group exchange
    Doing Diffie-Hellman key exchange with hash SHA-256
    WARNING - POTENTIAL SECURITY BREACH!
    The server's host key does not match the one PuTTY has
    cached in the registry. This means that either the
    server administrator has changed the host key, or you
    have actually connected to another computer pretending
    to be the server.
    The new rsa2 key fingerprint is:
    ssh-rsa 2048 ********
    Connection abandoned.
    Disconnected: User aborted at host key verification

    Anyone an idea what i'm doing wrong?

    Thx!!!

     
  • Mitch Capper

    Mitch Capper - 2013-03-12

    Peagent is putty's key manager, if you use passwords you do not use it. You are getting the error as you have never conntacted with putty or psftp to the host before, to fix this start putty/psftp outside of keepass and connect to the host, you will be prompted to accept the key and it will be saved on the machine. Once you do it will work on the future.

     
  • Vaako

    Vaako - 2013-03-13

    the putty trick did the job ;-) Thx!!!

    I had problems that the directory was not setup correctly.
    well I just had to alter it in: documents
    Not: /volume1/documents nor \DISKSTATION\documents

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks