Composite Key is Invalid error

  • Anonymous - 2012-08-29

    Hi. Great plugin, thanks a lot.

    I get an error when I change the master key for my database and then try to
    Steps to reproduce on version
    1) Set up Amazon S3 sync.
    2) Run KeePassSync Sync (successfully)
    3) Change Master Key
    4) Save Database
    5) Try to run KeePassSync

    Popup with error "The composite key is invalid! Please make sure the composite
    key is valid and try again" appears
    Reverting to original master key fixes the issue.
    I tried reinstalling KeePassSync from scratch unsuccessfully.
    Any hints on whether I'm doing something wrong or should I raise a bug for



    • woodchuckchuck

      woodchuckchuck - 2013-12-09

      I have the same issue. Did you ever get an answer to this or resolve the problem yourself?

  • woodchuckchuck

    woodchuckchuck - 2013-12-09

    The solution is to delete your keepass database on the AWS website : This worked for me.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks