• Nobody/Anonymous

    Ive been using keypass on linux for a few years, and i got a hold on keypassppc for my mobile yesterday. I copied the database from my linux version which ive named ".keydata", which makes the file hidden. However, trying to open this file on my windows mobile device, opens an empty database. Renaming this file to "keydata.kdb" on the wmdevice works fine, but for syncing purposes this is a rather hard way to do it. Is this a known bug?

    - Stian

    • Tobias

      Tobias - 2008-08-07

      KeePassPPC and KeePassSD are Windows Mobile programs and hence closer to the Microsoft world than the Linux world.

      In Windows-Land there are File-Suffix associations, so that the Browser knows which program belongs to which file suffix. E.g. *.jpg is probably associated with the Browser, *.txt with  the Notes... and tadaaa *.kdb with KeePassPPC.

      Also KeePassPPC filters for *.kdb files, otherwhise it would have to show all files you have in My Documents and subfolders and on the SD-MMCard and that could be a quite lengthy list with tons of "uninteresting" files. However you can change the file-type filter from "*.kdb" to "*.*" in the File Open Dialog.

      So if you rename the *.kdb file to *.my-extremely-secret-database-nobody-should-know-about
      then the browser doesn't know which program to open the file with anymore. I wouldn't consider this a bug. You can manually create ".keydata" as a file association with a registry editor by copying
      HKEY_CLASSES_ROOT\.kdb to HKEY_CLASSES_ROOT\.keydata  (including the Default subkey), but make a complete backup before you fiddle with that.



Log in to post a comment.