Problems with Cingular Wireless login

Help
2006-04-10
2012-11-19
  • Nobody/Anonymous

    Just set up my cingular wireless login like other online accounts using KeePass with KeeForm, only to run in to an error.  This web site has four fields.  The first three fields are the three digit area code, three digit prefix, and the four digit number followed by the password field.

    KeePass entered all ten digits in the first three entry fields.  This caused the failure.  Does anyone know how to set this up?

    My preference is to double click on the URL line for the account and KeeForm would do the rest.

    Help indeed appreciated.

    Sid

     
    • Nobody/Anonymous

      Badly designed login page :-)

      Example:
      tel # 111-222-3333

      Put only 111 in the User field.

      And the following into the notes field:

      Url-Override: cmd://KeeForm "{URL}" "{USERNAME}" "{PASSWORD}" "+{TAB 2}222{DEL 4}3333{ENTER}"

      (I assumed you have already https://www.myaccount.cingular.com in the URL field)

      Hope this helps.

       
    • Nobody/Anonymous

      Thanks for taking the time to get me started. I still have a problem.

      First it puts 111 in the first three entry fields and enters the password.  After that it appears to tab back only one field and I end up with the following ...

      111 111 3333 in the first three entry fields and
      ********** in the password field

      I tried several combinations of TAB and DEL but to no avail. 

      Please help.

      Sid

       
    • Nobody/Anonymous

      I just tested it again and it worked.

      I suggest you go through the the sequence "manually" to determine how many back-tabs you need (and so on).

      May be you need three "tabs back"? In this case you could try

      Url-Override: cmd://KeeForm "{URL}" "{USERNAME}" "{PASSWORD}" "+{TAB 3}222{DEL 4}3333{ENTER}"

       
    • Nobody/Anonymous

      It still doesn't work.  Is it possible that it is related to "IE 7.0 Beta"?  Please let me know if there is a work around this.

      Thanks very much for all your help.

      Sid

       
    • Nobody/Anonymous

      Sid,

      I don't think so, I tried "IE 7.0 beta 2 refresh" myself and it worked.

      I suggest you go through the the sequence "manually" to determine what key-presses you would need to navigate between the different fields(after KeeForm filled the fields).

       
    • Nobody/Anonymous

      I dont understand what you mean by "refresh".  I have 7.0 B2 and it is still not okay.  I have used the "debugscript" to my advantage by performing one action at a time but it doesn't matter how many {TAB x} sequences I have it still fills only the last entry field.  I give up.  But for this web site and another one i.e., Bank of America KeePass has been really very useful.

      I really feel very handicapped since I'm not a programmer and I cannot put my ideas to fruition.  I hope some day this useful utility becomes a parallel to RoboForm in functionality.

      Cheers!
      Sid

       
    • Nobody/Anonymous

      Try the following (withoout auto-type):

      Url-Override: cmd://KeeForm "{URL}" "{USERNAME}" "{PASSWORD}"

      KeeForm always places the cursor in the password field. From there try to navigate manually and enter 222 and 3333 in the second and third field. Write down the all the key presses you used and post them here. I will reply with correct auto-type string :-)

      PS
      just as FYI, here a history of IE 7.0 releases"
      http://www.filehippo.com/download_internet_explorer/

       
    • Nobody/Anonymous

      I just tried it on my workplace computer which by the way has IE6.0/SP2 and the sequence works like a champ.

      As suggested I'll install the most recent refresh of IE7.0/B2 on my home computer and give it another shot later tonight and post an update to this thread.

      Thanks for all your help.

      Sid

       
    • Nobody/Anonymous

      Now then there seems to be some kind of a problem with I dont know what.  I removed the older IE7.0 and reinstalled the newer IE7.0 and the first time around the entry fields were all in the correct sequence.  Thinking that the problem was resolved I added the {ENTER} statement and guess what I still have a problem ... The three entry fields are 111 111 3333 instead of reading 111 222 3333.

      I decided to remove IE7.0 completely.  I'm back to IE6.0.  Even with IE6.0, the first time around Keepass and Keeform entered all the three entry fields correctly.  Just like above I now made a change to the cingular entry.  I am sad to say that the problem hasn't gone away.

      I'm now convinced that it is not IE but instead could be with KeeForm or KeePass.  I do have the latest version of both of them.

      Here is a recap of manual entry as requested by you.

      First I remove the "debugscript"
      I click on the URL which launches the website and enteres the {USERNAME} into the first three fields enters the {PASSWORD} in the next field and stops.
      I manually did the following ...
      Press SHIFT KEY and then Press TAB once.
      With the SHIFT KEY pressed, press the TAB key again.
      The second entry field is selected.
      I just type in the three digit number.
      The cursor automatically moves to the next field.
      I press SHIFT and END.  This selects the field contents.
      I press the DEL KEY and then type the four digits.  The cursor automatically seeks the next field.

      Hope this is sufficient information.

      Thanks very much.
      Sid

       
    • Nobody/Anonymous

      Regarding:
      I press SHIFT and END. This selects the field contents.

      When I try this, it doesn't select the field contents. It actually jumps to next field (to the password field).

      But if I press "delete" 4 times instead of SHIFT END, it works.

      And that is exactly what

      Url-Override: cmd://KeeForm {URL} {USERNAME} {PASSWORD} "+{TAB 2}222{DEL 4}3333{ENTER}"  {KEEFORMDEBUG}

      does.

      May be somebody else could test this as well? I can not reproduce this issue.

      PS
      What about this "turn off debugscript"?

       
    • Paul

      Paul - 2006-04-13

      Can you simulate Ctrl-A to select all of the text?

      cheers, Paul

       
    • Nobody/Anonymous

      CTRL-A also jumps to the next field (instead of selecting the content of the field). There is a lot of javascript, which is supposed the make it easier for the user.

       
    • Nobody/Anonymous

      Today I realized one more piece of information.  My workplace computer has XP Prof while at home it is XP Home.  I have attempted numerous times at my workplace successfully (different key combinations).

      It appears that some settings on my home computer is preventing the execution.  Last night for some other reason I looked for the Java Icon to see the rev level but was unable to find it.  Maybe that is my problem.

      Cheers, Sid

       
    • Paul

      Paul - 2006-04-15

      There is no difference between XP Pro and Home that would account for the problems, they are the same program with the addition of domain authentication in Pro.
      Java version may make a difference.

      cheers, Paul

       
    • Nobody/Anonymous

      Here is my best guess.

      This cingular wireless login page uses a lot of javascript. Probably your security/javascript settings in your Home and Pro installations are different?

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks