Failed to load the specified file

Help
2010-01-27
2015-12-13
1 2 3 > >> (Page 1 of 3)
  • Alex Gantman

    Alex Gantman - 2010-01-27

    All of a sudden my master password doesn't work.  I get the error message

    Failed to load the specified file!
    The composite key is invalid!
    Make sure the composite key is correct and try again.

    I recovered some backed up copies of the kdbx file (back from the time I was able to open it successfully) but I get the same error when trying to open them now.  The only recent changes to my configuration were some MS security patches and I changed my Windows password.

    I am using KeePass 2.09 on Windows XP.

    Any suggestions?

    Thanks.
    -Alex

     
  • Paul

    Paul - 2010-01-27

    I think the solution is - change your Windows password back, open KeePass and change the master password to NOT use Windows User Account.

    cheers, Paul

     
  • Alex Gantman

    Alex Gantman - 2010-01-29

    I thought about that and will attempt to try it (our enterprise Windows password policy prevents me from re-using an old password).  However, I never set my master password to use my Windows User Account.  Is that a default setting?  I never checked that box when I logged into KeePass in the past.

     
  • Paul

    Paul - 2010-01-29

    If you didn't use WUA for the password - no it's not a default setting - then it is likely you forgot your password or used a key file with it.

    cheers, Paul

     
  • wonmuch

    wonmuch - 2010-09-15

    Hi all
    I am having exactly the same problem - I haven't changed the password and no key file ever used - it is not linked to my Windows user account. Must be a bug or something. I'm using V2.10

    Cheers

     
  • Shawn Collenburg

    Were you only using a password (e.g. not also a key file etc)?

    Try toggling the value for NativeKeyTransformations in  your KeePass.config.xml file:

    <Native>
    <NativeKeyTransformations>true</NativeKeyTransformations>
    </Native>

    Cheers,
    Shawn

     
  • unity100

    unity100 - 2011-04-26

    same happens for me. i have never used a key file, nor i have associated it with my windows account. actually nothing has changed on this computer even. all of a sudden, today i am getting this error and my 281 password big database doesnt work. this is not good.

     
  • unity100

    unity100 - 2011-04-26

    i have again imported my 280 passwords from kaspersky password manager through an arduous process involving a php script translating the records. if this composite key problem happens again, i will just have to drop keepass.

     
  • Paul

    Paul - 2011-04-27

    We have yet to see a case of KeePass actually failing to open a database when the correct credentials are supplied.
    Can you confirm that the database is correct?
    Have you tested a backup?
    Click the "show password" button and try again?
    Try another computer?

    cheers, Paul

     
  • unity100

    unity100 - 2011-04-27

    i tried in 2 different locations with the same keepass portable, same db, copied in exactly same fashion from master location to the mobile location. portable installation, everything is self contained. not only it didnt work in the master location, but it also failed in the mobile location all the same. so, thats 2 computers, 2 copies of the same installation (even including the db).

    and no, there were no issues with the password either. and yes, i had done 'show password', and copy pasted the password too.

     
  • Paul

    Paul - 2011-04-28

    Have you tried a backup of the database?

    cheers, Paul

     
  • unity100

    unity100 - 2011-04-28

    in case you have noticed, i have mentioned that there were already 2 exact copies of the same database in two different locations and i lost both.

     
  • wellread1

    wellread1 - 2011-04-28

    Unity 100,

    You say that all of the problem databases are copies of the master database (i.e. "copied in exactly same fashion from master location"). If the master database is the corrupt database, then copies will be corrupt too.  Do you have a genuine independent copy of the problem database? For example a known good earlier copy?

    -wellread1

     
  • Anonymous - 2011-05-15

    Hi,

    I think I have a similar problem.
    No any special changes lately here - only the latest Microsoft security patches.
    Now when I try to open my KeePass database I am always asked for the db_name.key where the db_name is the name of my database (db_name.kbdx). However I always used ONLY the Master Password. No "Key File". No "Windows User Account".

    Regards
    Tom

     
  • Paul

    Paul - 2011-05-15

    KeePass doesn't ask for a key file by name unless you have previously used one.
    Do you have more than one copy of KeePass running?
    Have you ticked the key file box?
    Can you open the database at all?
    What version of KeePass?

    cheers, Paul

     
  • Anonymous - 2011-05-15

    HI,

    Thanks for your notes. That's the problem - I have never used a key file.
    I am running one copy of KeePass. It is version 2.15.
    No - I am not ticking the key file box.
    At the moment I can't open the database at all.
    Other info: the operating system is Windows 7 Home Premium (Service Pack 1).

    Regards
    Tom

     
  • Paul

    Paul - 2011-05-16

    Make a temporary directory.
    Make a copy of your database in the temp directory.
    Download the zip version of KeePass and extract to the temp directory.
    Run KeePass from the temp directory and try to open the file.

    cheers, Paul

     
  • Matt

    Matt - 2011-06-23

    I had this issue a few minutes ago but managed to get back in.

    I have my .kbdx file in a truecrypt volume. And the truecrypt volume resides in my dropbox.

    My pc had locked up, so I force rebooted it.. and it came back with the error:

    Failed to load the specified file! The composite key is invalid! Make sure the composite key is correct and try again.

    I took a quick look in my dropbox and noticed a conflict on the truecrypt volume.

    I dismounted the normal file, mounted the conflicted file, and I could successfully log back into the .kbdx file.

    Hope this helps someone.

     
  • Paul

    Paul - 2011-06-23

    KeePass db in a Truecrypt container isn't really making the db more secure. A good master password and lots of encryption rounds (File > Database Settings > Security in V2, File > Database Settings in V1) is more than enough.

    cheers, Paul

     
  • vectorfrog

    vectorfrog - 2011-09-29

    Same exact problem here.  In my case, I do have a key file.  Everything worked great until I reinstalled windows 7.   Now I've installed KeePass and I'm getting the following error:
    "Failed to load the specified file! 

    The composite key is invalid!

    Make sure the composite key is correct and try again."

    I've moved the database into a tmp folder along with keypass, and still it won't work.  I've checked the ownership status of both the .key file and the .kdbx file.  I'm officially in panic mode, I had passwords that are not recoverable in there (like server administration passwords).  Please talk me off of this ledge.  I am screwed if I can't open up this file.

     
  • Paul

    Paul - 2011-09-30

    Are you sure you have the correct key or correct database?
    Is KeePass the same version?
    Did you use a password as well as a key file?
    If you used Windows User Account you are in trouble because that is machine and Windows installation dependent - there is a work around in a previous thread but it's difficult.

    cheers, Paul

     
  • vectorfrog

    vectorfrog - 2011-09-30

    I named the key the same as the database, so I know I'm using the right ones.  I do not know about the keepass version that I was using before.  The database is a .kdbx extension, and I downloaded the app from download.com, however, I have systematically tried opening the file with the following versions with the following results:

    keepass 1.20 - didn't recognize .kdbx file extension
    keepass 2.16 - threw invalid composite key error
    keepassX 0.4.3-win - threw "Wrong Signature" error

    The version that I thought I had before was keypass X, however, it looked more like keypass 2.16 .  There is a password on the file as well, but I know that I'm entering that correctly.  I did not have a Windows User Account enabled on it (I don't think this was even option on the version I had before).

    Any ideas?

    Thank you for the help Paul.

     
  • Paul

    Paul - 2011-10-01

    You definitely have a V2 database so 2.16 is the correct version (you should download from KeePass.info, 3rd party sites may not have the correct / latest version).

    If you used a key file and password then you have the wrong key file, the wrong password or both.

    cheers, Paul

     
  • vectorfrog

    vectorfrog - 2011-10-03

    Well, I don't think I have the wrong password or file, but it looks like I'm at the end of rope regarding ways to gain access.  Moving forward, I think I'll make it a practice to regularly export a csv file of the passwords into a true crypt folder, just in case I ever run into this again.

     
  • Paul

    Paul - 2011-10-04

    What happens when you forget the TrueCrypt password?

    The main issue seems to be "I re-installed Window". You need to test the important bits before such a major step.

    cheers, Paul

     
1 2 3 > >> (Page 1 of 3)

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks