Template URL Override

Help
2012-10-12
2012-11-19
  • Joachim Braun
    Joachim Braun
    2012-10-12

    Hello,

    I just played with the template feature of keepass. It's a nice feature to give users the ui for specific schemes.
    What I miss is if I define a URL override in the templates settings tab this is not inherited to entries referencing the template.

    So if I have multiple entries that use the same template I have to store the (same) url override string in all entries instead of only in the template.

    Any suggestions ?

    Regards
    Joachim

     
  • Paul
    Paul
    2012-10-13

    Works for me. I created a template with a new field and revised Auto-Type that includes the new field. New entries based on that template have the Auto-Type defined.

    cheers, Paul

     
  • Joachim Braun
    Joachim Braun
    2012-10-14

    Hi Paul,

    but not for me, let me explain what I do. I use V2.20 and have added a template with url override

    kdbx://
    

    and set it like this:

    cmd://wscript "{APPDIR}\Tools\kdbx.vbs" "{TITLE}"  "{PASSWORD_ENC}"
    

    In an entry I use this template. but it seems that my script is not called. Instead it's using an internal rule ? when I set this url override in the entry my script gets started.

    I tried it with the following settings in keypass.config.enforced.xml:

                <BuiltInOverridesEnabled>0</BuiltInOverridesEnabled>
                <SetToDefaults>true</SetToDefaults>
    

    what am I doing wrong ?
    Regards
    Joachim

     
  • Paul
    Paul
    2012-10-15

    I think you are confusing per entry URL override with global override.
    In a template you can set the override for only that URL, you cannot define a new protocol.
    If you want to define a new protocol you need to do it globally in Tools > Options > Integration.

    Assuming the URL in your entry is the full path to a database you want to open, e.g. "C:\Temp\Test.kdbx".
    To make this open in KeePass you would set the override for that entry to:
    cmd://wscript "{APPDIR}\Tools\kdbx.vbs" "{URL}" "{PASSWORD_ENC}"

    cheers, Paul