USAA.com & KeePass 1.06

Help
2006-10-16
2012-11-19
  • Nobody/Anonymous

    Since installing KeePass 1.06, I have been unable logon to USAA.com using the Global Auto-Type key. 

    It's hard to describe exactly what is happening (because I'm not sure myself) but somehow the cursor seems to jump around and the data doesn't go in the right place.  This was not a problem with KeePass 1.05 and there have been no apparent changes to the USAA web site in recent months. 

    I have tried this both with and without Auto-Type entries (and certain variations of those entries) and have been unable to resolve the problem. This behavior occurs both in Firefox 2.0RC2 and IE 7.0RC1.  I am able to drag and drop the username and password properly, but

    USAA usernames are typically numeric (no spaces or other special characters), while the passwords are typical alphanumeric combinations. 

    Any thoughts or suggestions would be greatly appreciated. 

     
    • Nobody/Anonymous

      It appears that auto-type (Crtl+V) has developed a quirk in v. 1.06.

      Unlike v. 1.05 “Use alternative auto-type method (minimize window)” must be selected in Settings — Advanced for auto-type (Crtl+V) to work correctly.

      Hopefully, this is only a temporary set-back.

       
    • Nobody/Anonymous

      Thank you for the reply.  Unfortunately, that setting has no affect on the issue I described, which has affected my login to USAA.com only.

       
    • Paul

      Paul - 2006-10-20

      Ctrl V seems OK to me - V1.06.
      Does the auto-type work if you use older browsers or in Notepad?

      cheers, Paul

       
    • Nobody/Anonymous

      I never said Auto-Type doesn't work in Version 1.06.  I said it doesn't work on USAA.com.  KeePass seems to work fine everywhere else, but it also worked on USAA.com prior to Version 1.06.

      Bob

       
    • Paul

      Paul - 2006-10-21

      Does it work on previous versions of the browsers?

      cheers, Paul

       
    • Dominik Reichl

      Dominik Reichl - 2006-10-21

      USAA.com uses some extremely mysterious automation of setting the focus to other controls. For example, when you are in the user name field and press Tab, first the link below gets the focus but then the focus is set immediately to the password field (after some milliseconds).

      Also, even more mysteriously, when you're in the browser window, set the focus to the user name field, switch to KeePass and just switch back to the browser window, the password field now got the focus!

      You'll have to experiment with some custom Auto-Type definitions. I'd guess having some delay after the first Tab will solve the global auto-type problem.

       
    • Nobody/Anonymous

      Dominik -

      Thanks for looking at this and confirming the problem.  At least I know I'm not completely insane. There is something very odd about the way the USAA web site responds to tabs, etc.  I haven't quite figured out how to work around this, but I will keep trying. 

      Also, I went back and did something I should have done at the beginning, which was to reinstall V1.05 and try again.  As you might expect, the behavior was the same as v1.06, which tells me the problems are the result of recent changes to the USAA web site.  It doesn't LOOK any different, but it certain behaves in a very odd way. 

      Anyway, my problem to solve ... thanks for your input. 

      Bob

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks