protecting an entry from change

Help
userxyz
2012-09-26
2012-11-19
  • userxyz

    userxyz - 2012-09-26

    Is there any way to lock down an entry in Keepass so that I do not accidentally make changes to it?  On some Terminal screens for command line interface and a few other instances, the Auto-type feature does not work, and in those cases I have to reveal the password and manually type it. Occassionally, I have found myself typing or erasing a character or two in the password field without realizing it.  I would just as soon not have to wonder whether I altered it like that.  So, can I lock down certain entries? Thanks.

     
  • steelej

    steelej - 2012-09-26

    It may depend on exactly what you need to do and what OS you are using.

    I frequently use PuTTY for example to give me command line access to computers or network devices and here you should be able to exploit the "Right Click" feature in PuTTY to copy the clipboard to the target terminal window. Even if the following is not directly applicable then there may be an idea you can develop.

    I have not actually tried the following (I have used Excel Macros for generating custom strings on the  Windows clipboard to automate logging onto network devices with elevated privileges by creating the appropriate string from fields on a spreadsheet) but  the following should work.

    Create the user name and password in the normal way, If additional information is required (e.g. an elevation password for network devices) then create these in Custom fields.

    Then create a new custom field using references to the other data and then use KeePass to copy the custom logon string created in the Custom field  to the clipboard and then paste it into your target Window.

    This way you never need to open the entry and copy the password minimising the risk of accidental change.

    Taking a backup of your database will protect you against finger trouble of course.

     
  • Paul

    Paul - 2012-09-26

    There is no way to lock down an entry, but there are several ways around TS screens.
    1. Set the TS screen so it's not maximised. Bring KeePass to the front, right click on the entry and select Perform Auto-Type.
    2. Use the RDCAutoTypeAndTCATO plug-in.
    3. Drag n drop to Notepad++ and work from there.

    cheers, Paul

     
  • userxyz

    userxyz - 2012-10-04

    Hi, pail459.  There is a problem with using the first method, which I can describe easily enough. I have systems running as virtual machines in Oracle VBox, for example, and one of them using Linux OS makes use of LUKS whole disk encryption on it such that, when the machine is booting, initially it has a terminal interface presenting a prompt for me to enter a password, which does not echo any sort of characters back at me as they are typed.  I have tried using the Perform Auto-Type procedure for entering this password, but it is not recognized apparently.  Part of the difficulty here, you see, is that the mouse has to remain in the window of the virtual machine for it or the keyboard to be interpreted. However, to right-click Keepass entry requires that I move it into a separate window.  :(

    The second option of using a plug-in runs contrary to my normal practice of avoiding plug-ins altogether for sake of security.

    Consequently, the third option, although somewhat manual and less efficient, is viable. I have adopted it without complaint. Thanks for your suggestions.  :)

     
  • Paul

    Paul - 2012-10-04

    1a. Open KeePass and set "Auto-type selected entry" hot keys - Tools > Options > Integration. V2 only.
    Set the TS screen so it's not maximised. Bring KeePass to the front and left click on the entry you want. Bring the TS to the front and press the "Auto-type selected entry" hot keys.

    cheers, Paul

     
  • userxyz

    userxyz - 2012-10-04

    Hi, pail459.  This is not effective against this particular kind of window, which is apparrently quite resistent to allowing any sort of copy or pastes of data, probably for security reasons. It appears to want the input directly from the keyboard, without exception, at least this is what I appear to be observing. Anyway, no major heartache. Thanks, again. 

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks