Auto-Type Stopped Working

Help
Murray
2014-04-16
2014-12-10
  • Murray

    Murray - 2014-04-16

    After upgrading to 2.26 my auto-type seems to have stopped working. This is on a Windows XP machine, it still works fine on my Windows 7 netbook.

    I don't use the global hot-key feature, instead I open the web page I want to log into and put the cursor in the username field, switch to KeePass, find the entry I want and press ctrl-V. The web browser then switches to get focus but nothing else happens.

    I've tried several websites and even KeePass's test login page.

    Doing the same but using ctrl-C does copy the password onto the clipboard and I can paste it into the website ok. Right-clicking an entry and clicking "Perform Auto-type" does exactly the same thing (i.e. switch to browser window but nothing else).

    I don't have any clip-board related software installed and I haven't changed any of the KeepPass options since upgrading to 2.26. I've tried using Opera (my normal browser) and Firefox, and I've even tried just opening Notepad and seeing if it will auto-type into there (nothing).

    All of the entries are set to inherit their parent's Auto-Type settings, which is set to: {USERNAME}{TAB}{PASSWORD}{ENTER}

    Under Tools -> Options -> Advanced -> Auto-Type I've got the following items ticked:
    An entry matches if its title is contained in the target window title
    Prepend special initialization sequence for Internet Explorer windows
    Send Alt keypress when only the Alt modifier is active
    Ensure same keyboard layouts during auto-type

    All other entries in the Auto-Type section of the Options are unticked. I think these are just the program defaults, I don't remember changing anything.

    TCATO is turned off for all entries.

    I've tried adding {DELAY=20} to the start of one entry to see if that helps but still nothing.

    Is there anything else I can try?

     
  • wellread1

    wellread1 - 2014-04-17

    It sounds like you are doing everything right. You could try the following:

    First try rebooting the computer. XP sometimes benefits from an occasional reboot.

    Determine if KeePass settings are a problem
    Reset your settings to default.

    • With KeePass closed find and rename the active KeePass.config.xml. See http://keepass.info/help/base/configuration.html for locations. The default location for installed KeePass is the 'Local' location. The default location for portable KeePass is the 'Global' location. The active config file will have a Date Modified corresponding to the last time you exited KeePass.
    • Start KeePass. It will start with default settings.
    • Test Perform Auto-Type (Ctrl-V)
    • If desired after testing is complete, exit KeePass and rename the original config file back to keepass.config.xml

    Determine if some optional aspect of the Windows environment is the problem

    • While still using default settings above start Windows in safe mode
    • Run KeePass and test Perform Auto-Type (Ctrl-V)
     
  • Murray

    Murray - 2014-04-27

    I've been on holiday for a week and when I returned this morning I found that auto-type now works again! All I can assume is that something weird happened and it's now sorted itself out. I normally close down my PC every night before heading home, so I don't think it was anything to do with needing a reboot, but who can tell. Anyway I'm a happy camper again!

     
  • Charlie

    Charlie - 2014-12-10

    I have the same problem. Keepass 2.28 auto type no longer works with Firefox 34.0.5. It still works with internet explorer. I can individually copy the user id and password into firefox, but not auto type (Ctrl+V) both fields. I get a password error. I tried resetting the config file with no benefit. Auto-Type settings are set to: {USERNAME}{TAB}{PASSWORD}{ENTER}. Any ideas what I can try next.

     
  • wellread1

    wellread1 - 2014-12-10

    KeePass auto-type works fine with Firefox 34.0.5. Some things you can check:

    • Try to auto-type (Ctrl-V) on a test page (e.g. http://keepass.info/help/kb/testform.html)
    • Make sure that the entry does not contain custom auto-type sequences that might be matching the Window Title (browser tab title) unexpectedly.
    • Double check that you haven't overridden the default auto-type sequence on the entry's Auto-Type tab.
    • Make sure that you selected the correct entry when you used auto-type (Ctrl-V).
    • Reboot the computer.
     
    Last edit: wellread1 2014-12-10
  • Charlie

    Charlie - 2014-12-10

    The userid and password was correct using the test site. I tried rebooting the system. The default auto-type settings were fine. The correct entry was selected. I'm not sure what you meant by point 2 regarding matching the Windows Title.
    I deleted all saved password in firefox and that seems to have fixed the problem.

     
  • Charlie

    Charlie - 2014-12-10

    OK. The problem only occurs for sites that I have a saved password for. After autotype enters the userid, it seems that Firefox AND Keepass both enter the password giving me an invalid password.

     
  • wellread1

    wellread1 - 2014-12-10

    You might want to disable the Firefox password manager to avoid confusing competitive behavior between Firefox and KeePass.

     

Log in to post a comment.