SourceForge has been redesigned. Learn more.
Close

Acces Keepass with a different windows user?

Help
sporty222
2013-11-16
2013-11-18
  • sporty222

    sporty222 - 2013-11-16

    Hello, my Windows user does not work anymore and I had to create a new one. UNfortunately I cannot open my KeePass kdb file with the new user? I know the password. How can I access the file? Thanks for any help, all my Passwords are in the database...

     
  • wellread1

    wellread1 - 2013-11-16

    Based on the file extension you mention you are using KeePass 1.x. In that case you can not link the database to the Windows User Account so the Windows user does not affect whether you can open your KeePass database.

    If you are using KeePass 2.x did you link the database to the Windows User Account? If so you will need to restore your old windows account.

    Assuming you did not link the KeePass database to the Windows User Account then verify that:

    1. You did not switch major versions of KeePass when you reinstalled it e.g. KeePass 1.x to KeePass 2.x.
    2. You are attempting to open the correct database e.g. Press Cancel on the "Enter Master Key" dialog. KeePass will open without a database. Then use File>Open>Open File... to navigate to your database. Note: This possibility is likely if you have installed a fresh copy of KeePass on a fresh Windows installation and did not move your old KeePass database.
    3. If you are using a key file, verify that you have selected the key file in the "Enter Master Key" dialog. (Press the folder button to the right of the key file selection drop down on the "Enter Master Key" dialog and navigate your key file (not database))
    4. You have not made any typos when entering your password (when entering your password press the reveal password button "..." to the right of the password entry field on the "Enter Master Key" dialog.
    5. You did not use any plugins that change how the KeePass database is opened on you original KeePass installation.
    6. If you have reason to believe everything else is OK, and you have the correct Master Key, but the database might have been damaged (e.g. by a hard drive failure) you might be able to recover some or most of the database using the repair database feature.
     
    Last edit: wellread1 2013-11-16
    • sporty222

      sporty222 - 2013-11-17

      Thanks for the answer. Yes, I am using 1.25 and just started an update for 1.26.
      All questions yes, I also tried already the repair function but the result is:
      error code: 0x0000000A
      Invalid/corrupted file structure
      Group 0/7
      entry 0/33
      meta 0.

      Does this mean I have to somehow recreate all my Passwords?
      I will store a copy of the file next time...

       
      • wellread1

        wellread1 - 2013-11-17

        It is not proof of a corrupt database. It is only evidence that it can't be repaired for whatever reason including being provided the wrong Master Key. The Group 0/7 and entry 0/33 messages are suggestive that Database might be small and the wrong Master Key was provided or that the recoverable records are few. However the file does appear to be a 1.x database at least.

        A newly created database (which contains 6 groups and 3 entries by default) would generate the following error if a user tried to repair it using the wrong Master Key.

        error code: 0x0000000A
        Invalid/corrupted file structure
        Group 0/6
        entry 0/3
        meta 0.

         
        Last edit: wellread1 2013-11-17
  • sporty222

    sporty222 - 2013-11-18

    I checked the master Password, it is correct. Also tried to start the repair function again, same result. It does not work unfortunately. I will start to recreate the Passwords..
    Thanks

     
  • Paul

    Paul - 2013-11-18

    Have you confirmed you are attempting to open the correct database?
    Did you use a key file as part of your master password?

    cheers, Paul

     

Log in to post a comment.