Auto-Type Not Working On Some Sites

Help
lsj23sm23c
2012-05-08
2012-11-19
  • lsj23sm23c

    lsj23sm23c - 2012-05-08

    Hi there.
    First time poster here. Been using KeePass for years, and love it.

    I am using Chrome Portable v18.0.1025.168.
    I am using KeePass v1.22.

    I've been having issues lately where some sites don't work with Auto-Type at all.

    Please don't tell me how to use Auto-Type, I've been using it for years. I've got hundreds of sites KeePass works perfectly for.

    Its just that on some sites, it just does not work at all.

    I will list more sites soon.

    For instance, it doesn't work for me here:
    http://www.inghams.com.au/consumer/

    I use the following Auto-Type-Window: Ingham's Chicken products | Chicken recipes | Club Ingham chicken recipe club - Google Chrome

    Could you please test and let me know if it works for you or doesn't work for you?

     
  • Paul

    Paul - 2012-05-08

    I see an issue with the apostrophe. Depending on the font you have used - I cut and pasted your text - it may not work.
    It is consistent with this sequence: Auto-Type-Window: Ingham*

    cheers, Paul

     
  • wellread1

    wellread1 - 2012-05-08

    Can you describe how the login fails. KeePass 2.19, using the auto-type sequence {C:Username & Password}{DELAY=4}{HOME}+{END}{USERNAME}{TAB}{HOME}+{END}{PASSWORD}{ENTER} types the username in the username field and apparently the masked password in the password field in chrome 18.0.1025.168 m on http://www.inghams.com.au/consumer/.

    I am not located in Australia so I can't create an account to verify a successful login.

    -wellread1

     
  • Andrew

    Andrew - 2012-10-09

    I have met with a very similar problem.

    I've been using auto-type for years - and I share a database between 2 different Windows pcs.  One one computer (Win7) it works great.  On the other computer, after I upgraded to Win 7 auto-type stopped working.

    When I auto-type, the username is entered correctly.  However, the password is not: it seems that once the cursor goes back, it starts overwriting the original characters in the text box and the entered password is shorter than the one it is supposed to be.

    Don't know why this is happening and I'm working around by copying and pasting the password instead.

     
  • wellread1

    wellread1 - 2012-10-09

    That sounds like TCATO is enabled on that entry, but it is not compatible on the site.  Try disabling TCATO (Edit the offending  entry; select the Auto-Type tab; & uncheck "Two-channel auto-type obfuscation"

    -wellread1

     
  • Andrew

    Andrew - 2012-10-09

    Thanks.
    As a matter of fact I do use TCATO, so I will disabling it tomorrow and see if it works or not.

    The site itself should be compatible: Google authentication on Chrome Browser.  Again, it works on one pc but not on the other (as described above).

     
  • Andrew

    Andrew - 2012-10-10

    It seems as if for some reason it is not working with GMail on one pc but it does on another.
    Even without TCATO, my GMail password is not entering correctly.  This time, the password is left blank.
    Since I have not come across this anywhere else, I will check whether this is due to one of my modifications to Auto-Type and write to the forum to explain what happened (for other user's information).

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks