[Linux] Plugins don't compile in 2.18 o...

  • Markus Birth

    Markus Birth - 2012-05-10

    Using KeePass 2.17 together with Mono on a Ubuntu 12.04 machine, all PLGX-Plugins work fine.

    As soon as I try 2.18 or 2.19, I get errors about broken plugins and they don't compile anymore.

  • Paul

    Paul - 2012-05-10

    Do the same plug-ins and KeePass versions work on Windows?
    What error messages?

    cheers, Paul

  • Markus Birth

    Markus Birth - 2012-05-10

    I don't have a Windows ready ATM. The error message is:

    "The following plugin is incompatible with the current KeePass version:

    Have a look at the plugin's website for an appropriate version."

    And this appears for all 4 plugins I used under 2.17.

  • Paul

    Paul - 2012-05-10

    Tested on KeePass 2.19 and FavIcon 1.6 (2011), Win XP. Works OK.
    Sounds like Mono strangeness, hopefully Dominik will have some ideas.

    cheers, Paul

  • Dominik Reichl

    Dominik Reichl - 2012-05-10

    Unfortunately not. I've tested Favicon Downloader with both the keepass2 package as well as the portable 2.19 version (under Kubuntu 12.04, Mono and it works perfectly fine for me.

    Best regards

  • Walker

    Walker - 2012-05-10

    I´ve got a plugin-problem under Kubuntu too.
    Plugin: DatabaseBackup (dbBackup.plgx)
    Error-Message: The following Plugin is incompatible with the current KeePass version:
                                  Have a look at the plugin´s website……..
    KeePass-Version: 2.19 (via ppa.launchpad.net/jtayler)

    Under Windows it works well.
    I think it´s a problem with mono


  • Luckyrat

    Luckyrat - 2012-05-11

    Ubuntu ships an incomplete version of Mono so make sure you have installed the mono-complete package.

    sudo apt-get install mono-complete

    KeePass 2.18 defaults to using .NET 4 runtime libraries (as opposed to .NET 2 libraries in 2.17 and earlier) so the problems could be related to that (maybe the .NET 4 libraries are not fully installed unless you get the mono-complete package).


  • Walker

    Walker - 2012-05-12

    sudo apt-get install mono-complete

    Thanks for your advice - it works !

  • Julian Taylor

    Julian Taylor - 2012-05-12

    you don't need mono-complete
    you only need a fitting compiler which is in the mono-dmcs package in ubuntu oneiric or newer and mono-gmcs in natty or older

  • Markus Birth

    Markus Birth - 2012-05-14

    Okay, I figured it out: mono-dmcs is needed for the Mono 4.0 compiler (KeePass 2.18+), mono-gmcs is needed for the Mono 3.x compiler (KeePass up to 2.17).


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks