KeePass2.23 on Mac OS X 10.9.2

Help
scason
2014-03-04
2014-04-03
  • scason

    scason - 2014-03-04

    i have installed mono 3.2.7 and KeePass 2.23 on Mac, per instructions, and am not able to get it to work. initially, i would get errors then i ran across a old post that indicated i should modify my KeePass.config.xml file to include:

        <TrayIcon>
            <ShowOnlyifTrayed>true</ShowOnlyifTrayed>
            <SingleClickDefault>false</SingleClickDefault>
        </TrayIcon>
    

    this actually allowed me to get past the error and displayed the KeePass dialog w/ the update dialog active. the app seemed to react to the mouse pointer VERY VERY VERY sluggish and slow. i was unable to click the "close" button and had to 'X' out of the update dialog but had to wait for the 'X' button to become active.

    after that when i clicked on the "open file" button, mono became unresponsive and i had to force it to end.

    anyone have any ideas? i run KeePass on windows and it works quite well. i really like the app, just wish i could get it to work on my new mac.

    incidentally, when i tried to launch it from a terminal window i got the following:

    Scotts-MacBook-Pro:~ scason$ mono /Applications/Keepass/KeePass2.23.app/Contents/MacOS/keepass.exe
    mono(938,0xb04bf000) malloc: error for object 0x1fbbba0: pointer being freed was not allocated
    set a breakpoint in malloc_error_break to debug
    Stacktrace:

    at <unknown> <0xffffffff>
    at (wrapper managed-to-native) System.Windows.Forms.XplatUICarbon.ReceiveNextEvent (uint,intptr,double,bool,intptr&) <0xffffffff>
    at System.Windows.Forms.XplatUICarbon.GetMessage (object,System.Windows.Forms.MSG&,intptr,int,int) <0x00077>
    at System.Windows.Forms.XplatUI.GetMessage (object,System.Windows.Forms.MSG&,intptr,int,int) <0x00026>
    at System.Windows.Forms.Application.RunLoop (bool,System.Windows.Forms.ApplicationContext) <0x00b2f>
    at System.Windows.Forms.Application.Run (System.Windows.Forms.ApplicationContext) <0x0004f>
    at System.Windows.Forms.Application.Run (System.Windows.Forms.Form) <0x00037>
    at KeePass.Program.Main (string[]) <0x0096b>
    at (wrapper runtime-invoke) <Module>.runtime_invoke_void_object (object,intptr,intptr,intptr) <0xffffffff>

    Native stacktrace:

    Debug info from gdb:

    Abort trap: 6
    Scotts-MacBook-Pro:~ scason$ Executing commands in '/tmp/mono-gdb-commands.JoRxbF'.
    (lldb) process attach --pid 938
    error: Aborting reading of commands after command #0: 'process attach --pid 938' failed with error: attach failed: process did not stop (no such process or permission problem?)
    (lldb)

    thanks,

    scott

     
    Last edit: scason 2014-03-04
  • wellread1

    wellread1 - 2014-03-06

    I haven't any experience with KeePass on Mac OsX but my impression of posts on the general subject of KeePass 2.x running on linux type platforms is that there are enough material differences between Microsoft .NET and its substitute, mono, that it might be advisable to restrict your initial installation to the recommended versions. Currently the http://keepass2.openix.be/ site links to mono version 3.2.3 rather than the most recent release v 3.2.7. The site also specifies that Xquartz 2.7.4 should be installed.

     
  • scason

    scason - 2014-04-03

    ok. am now running keepass2.23 and mono3.2.7 and it appears to work. i run it as a background task via shell script...

    /Applications/Keepass/KeePass2.23.app/Contents/MacOS/KeePass2.23
    

    however, when i quit the app i get the following. any ideas?

    [1] 603
    scotts-mbp:~ scason$
    Unhandled Exception:
    System.ArgumentException: A null reference or invalid value was found [GDI+ status: InvalidParameter]
    at System.Drawing.GDIPlus.CheckStatus (Status status) [0x00000] in <filename unknown="">:0
    at System.Drawing.Graphics.GdipMeasureString (IntPtr graphics, System.String text, System.Drawing.Font font, System.Drawing.RectangleF& layoutRect, IntPtr stringFormat) [0x00000] in <filename unknown="">:0
    at System.Drawing.Graphics.MeasureString (System.String text, System.Drawing.Font font, Int32 width, System.Drawing.StringFormat format) [0x00000] in <filename unknown="">:0
    at (wrapper remoting-invoke-with-check) System.Drawing.Graphics:MeasureString (string,System.Drawing.Font,int,System.Drawing.StringFormat)
    at System.Windows.Forms.TextRenderer.MeasureTextInternal (IDeviceContext dc, System.String text, System.Drawing.Font font, Size proposedSize, TextFormatFlags flags, Boolean useMeasureString) [0x00000] in <filename unknown="">:0
    at System.Windows.Forms.TextRenderer.MeasureText (System.String text, System.Drawing.Font font, Size proposedSize, TextFormatFlags flags) [0x00000] in <filename unknown="">:0
    at System.Windows.Forms.ToolStripItem.OnParentChanged (System.Windows.Forms.ToolStrip oldParent, System.Windows.Forms.ToolStrip newParent) [0x00000] in <filename unknown="">:0
    at System.Windows.Forms.ToolStripItem.set_Parent (System.Windows.Forms.ToolStrip value) [0x00000] in <filename unknown="">:0
    at (wrapper remoting-invoke-with-check) System.Windows.Forms.ToolStripItem:set_Parent (System.Windows.Forms.ToolStrip)
    at System.Windows.Forms.ToolStripItemCollection.Remove (System.Windows.Forms.ToolStripItem value) [0x00000] in <filename unknown="">:0
    at System.Windows.Forms.ToolStripItem.Dispose (Boolean disposing) [0x00000] in <filename unknown="">:0
    at System.Windows.Forms.ToolStripDropDownItem.Dispose (Boolean disposing) [0x00000] in <filename unknown="">:0
    at System.Windows.Forms.ToolStripMenuItem.Dispose (Boolean disposing) [0x00000] in <filename unknown="">:0
    at System.ComponentModel.Component.Finalize () [0x00000] in <filename unknown="">:0

    [1]+ Exit 255 ./documents/keepass.sh

     
  • David Lechner

    David Lechner - 2014-04-03

    This error seems to happen with recent versions of KeePass and Mono. It happens on Linux too. I think it happens because something is being disposed in the wrong order. Since it has to do with the menu, it is not anything to worry about.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks