Google Chrome as standard

Help
Koolmees
2014-05-28
2014-06-01
  • Koolmees

    Koolmees - 2014-05-28

    I use Keepass 2.26 and my standard browser is Google Chrome. I unstalled the plugin for Google Chrome, but Keepass always use Internet Explorer. How can I change this?

     
  • Paul

    Paul - 2014-05-28

    KeePass does not call a specific browser unless you have set a URL override. Most likely Windows is not configured to allow Chrome to open URLs - you can test this by running these commands: Win R > cmd > http://keepass.info
    If that opens in IE then you need to tell Chrome to be your default browser - I'm not sure how to do that.

    cheers, Paul

     
    Last edit: Paul 2014-05-28
  • Koolmees

    Koolmees - 2014-05-31

    Google Chrome is my standard browser and indeed: Internet Explorer opens when I overwrite URL's with KeepassForm. How can I set that it opens with Google Chrome?

     
  • wellread1

    wellread1 - 2014-05-31

    Are you referring to the KeePassForms plugin? If you believe the issue is with KeePassForms plugin your best bet is to post in the KeePassForms discussions forum at https://sourceforge.net/p/keepassforms/discussion/?source=navbar.

    If you believe the issue is not with the KeePassForms plugin remove the plugin and see if you still have the problem.

    Also if you mean override URLs then open the URL override option in Tools>Options>URL Override(button) and uncheck the overrides that include {INTERNETEXPLORER} in them.

     
  • Paul

    Paul - 2014-06-01

    Have you tried setting Chrome as your default browser?
    Please explain exactly how you open a URL that results in Internet Explorer running?

    cheers, Paul

     
  • Koolmees

    Koolmees - 2014-06-01

    Chrome is my default browser. In Keepass I click on the link and Internet Explorer opens every website. The command is :

    cmd://"{APPDIR}\KeeForm.exe" "{URL}" "{USERNAME}" "{PASSWORD}" "{ENTERFORM}"

    I have uninstalled the plugin, but it does not help.

     
  • wellread1

    wellread1 - 2014-06-01

    Verify that Chrome is your default browser by opening a URL from the Windows Run dialog (press Win+R, enter http://www.amazon.com into the the Run dialog, then press OK). Chrome should open with an an Amazon page showing. If Internet Explorer opens you need to set your default browser to Chrome.

     
    Last edit: wellread1 2014-06-01
  • Koolmees

    Koolmees - 2014-06-01

    Chrome is the standard browser and so Chrome from the Windows Run dialog.

     
  • wellread1

    wellread1 - 2014-06-01

    To verify that KeePass is operating correctly replace the entry's URL with a simple URL e.g. http://www.amazon.com and verify that Chrome opens when you click on the URL.

    Based on a quick read of KeeForm FAQ and Installation page it looks like Keeform might be designed for IE Explorer while KeeFormFF.exe is designed for firefox. I don't see Chrome explicitly mentioned. Since, the KeePass URL is invoking an external program i.e. KeeForm.exe, It seems likely that KeeForm is controlling which browser opens.

    Note: KeeForm is a third party plugin. There is no particular insight at this forum regarding KeeForm's behavior.

     
    Last edit: wellread1 2014-06-01

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks