Portable KeePass 2.19 does not start

  • James M. Moe

    James M. Moe - 2012-05-16

    opensuse v12.1
    linux 3.1.10-1.9-desktop x86_64
    mono v2.10.6
    keepass v2.19

    When I attempt to start KeePass in linux, I get this:

    :..diy/keepass-mono> mono KeePass.exe
    Unhandled Exception: System.TypeLoadException: Could not load type 'KeePass.Program' from assembly 'KeePass, Version=, Culture=neutral, PublicKeyToken=fed2ed7716aecf5c'.
    [ERROR] FATAL UNHANDLED EXCEPTION: System.TypeLoadException: Could not load type 'KeePass.Program' from assembly 'KeePass, Version=, Culture=neutral, PublicKeyToken=fed2ed7716aecf5c'.

    Now what?

    ..diy/keepass-mono> mono --version
    Mono JIT compiler version 2.10.6 (tarball Sat Oct 29 18:16:09 UTC 2011)
    Copyright (C) 2002-2011 Novell, Inc, Xamarin, Inc and Contributors. www.mono-project.com
        TLS:           __thread
        SIGSEGV:       altstack
        Notifications: epoll
        Architecture:  amd64
        Disabled:      none
        Misc:          debugger softdebug 
        LLVM:          supported, not enabled.
        GC:            Included Boehm (with typed GC and Parallel Mark)
  • Julian Taylor

    Julian Taylor - 2012-05-16

    try if one of these works:
    mono -runtime=v2.0 ./KeePass.exe
    mono -runtime=v4.0 ./KeePass.exe

  • Gotit

    Gotit - 2012-05-24

    I have (had) the same problem and the first one worked for me.  Thanks!!

  • Gotit

    Gotit - 2012-05-24

    However, I now get this message in Terminal:
    "WARNING: The runtime version supported by this application is unavailable.
    Using default runtime: v2.0.50727"


    "Unknown errno: Transport endpoint is not connected"

    I have mono runtime installed

  • Julian Taylor

    Julian Taylor - 2012-05-25

    you might need some extra packages to run with 2.0 runtime, install:
    libmono-corlib2.0-cil libmono-system2.0-cil  libmono-winforms2.0-cil

  • opepe

    opepe - 2012-05-31


    i have almost the same problem. I have the same configuration as jimoe from post #1.
    A few days ago keepass used to work without a problem. Im not sure what changed, but today im having big trouble with keepass.
    I have some different cases:

    1. mono KeePass.exe doesnt launch a gui and just quits without any messages. mono keepass.exe -help launches the help website in my browser however.
    2. keepass starts, but the gui is unusable, just a windows with random colors inside.
    3. keepass starts, but when i want to open a kdbx file the file is never opened. I enter the master password and then nothing happens, although the cpu load goes up for a while when decrypting the file. After the load goes low the file normaly openes, but now nothing happens.

    I tried to create a new user and use kde or icwm as desktop, but with the new user i always get case 3.

    I dont get it, what can i do? I tried reinstalling mono and keepass, but nothing helped.
    When i launch keepass from my normal account i randomly get all three cases from above.
    What could have messed up keepass so much, since it used to work just fine some days ago.

    The suggestions from jtaylor108 dont help.

  • opepe

    opepe - 2012-06-03

    Hi again, today everything works again. I just dont know what caused the trouble, just installed some package updates and now everythings ok.

  • Paul

    Paul - 2012-06-04

    Were they mono updates?

    cheers, Paul

  • opepe

    opepe - 2012-06-04

    No, those werent mono updates but some python, php, systemd, openssl, upower, snmp, svn, bsdtar, mozilla-nspr, serf and gvfs updates.

  • RockDrill'a

    RockDrill'a - 2012-06-06

    Hi there! There's closely the same problem in other topic:
    Read post #13 in that  topic. Yepp, I'm lucky. :-]

    BTW, I'm confused about whether to post new feedback about this issue.

    PS: I'm Debian user, and there's no updates for Mono for last week or so (on first PC - debian testing i386).
    Second PC (debian testing amd64) has clean install one day ago or so.
    If it helps, OS was installed at first PC in later March and, of course, there were updates for Mono too.
    Maybe, newer Mono builds are misbehaving in clean install / configuration, but older ones aren't ?

    PPS: english isn't my native language, as you've seen. Corrections are welcome, blind criticism is lesser.

  • DeegC

    DeegC - 2012-10-03

    I got the OP problem and I solved it by installing mono-devel.

  • James M. Moe

    James M. Moe - 2012-10-04

    Huh! Yes, installing the mono-devel package got KeePassX working here as well. It is rather unfortunate that I need the development package to run an end-user program.

  • James M. Moe

    James M. Moe - 2012-10-04

    I just tried doing something useful with KeePass v2.20.1: import a database from a v1.x file. The error message stated (paraphrasing) "This can only happen on a real Windows OS since the import facility only exists there. You are SOL"


  • Paul

    Paul - 2012-10-05

    The KeePass V1 import routines are in a DLL and that only works in Windows.
    You could export the V1 database as a CSV and then import it into V2.

    cheers, Paul


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks