CTRL+U opens Safari instead of default browser

Help
StaticBlue
2013-07-31
2013-07-31
  • StaticBlue

    StaticBlue - 2013-07-31

    After installing the latest version over the top of the previous release, I can no longer open the default browser through Keepass. Normally it would open Firefox and the URL to what was stored in KeePass.

    Now it opens the URL with Safari. How do I revert this to Firefox?

    Windows 7, 64bit.
    KeePass 2.23

    Cheers :)

     
    Last edit: StaticBlue 2013-07-31
  • wellread1

    wellread1 - 2013-07-31

    Confirm that Firefox is your default browser.

     
    Last edit: wellread1 2013-07-31
    • StaticBlue

      StaticBlue - 2013-07-31

      I have confirmed this, as well any emails with links arriving in still open with the default browser. Same with links in words or PDF documents.

      Cheers :)

       
  • wellread1

    wellread1 - 2013-07-31

    If Firefox is the default browser but clicking on a URL in KeePass opens a different browser, then a URL Override has been set. Check Tools>Options>Integration(tab). The defaults is "Override all URLs" is unchecked (and blank) as are all Scheme-Specific URL Overrides except ssh (URL Scheme Overrride button).

    A URL Override can be used in the URL field itself but it would be plainly visible.

    Also: The URL Overrides are settings that are stored in the KeePass.config.xml. They will not change as the result of an upgrade because the upgrade does not overwrite this file.

     
    Last edit: wellread1 2013-07-31
  • StaticBlue

    StaticBlue - 2013-07-31

    All are blank except ssh

    Cheers :)

     
  • wellread1

    wellread1 - 2013-07-31

    I would double check the default programs/file associations in control panel and reset Firefox to be the default even if it says it is. Did you install or update any apple products recently?

    Browsers have a habit of trying to take over the defaults. KeePass doesn't care what you use.

     
    Last edit: wellread1 2013-07-31
  • wellread1

    wellread1 - 2013-07-31

    Do you have any plugins installed?

     
  • StaticBlue

    StaticBlue - 2013-07-31

    None whatsoever. It has worked perfectly with opening Firefox for many years with all previous versions.

    I'm using the latest release of KeePass, and the latest release of Firefox.

    Cheers :)

     
  • wellread1

    wellread1 - 2013-07-31

    Well, you could temporarily uninstall Safari. That will either give Firefox a chance to reassert itself or it will generate an error that might be informative.

    You could also try the standard computer reboot.

     
  • StaticBlue

    StaticBlue - 2013-07-31

    Uninstalling Safari worked.

    Thank you :)

     

Log in to post a comment.