kdbx file truncated on save

  • Whoszat

    Whoszat - 2013-09-06


    I'm using the 2.23 Mono version on debian (Squeeze - oldstable) without any plugin.
    I have many .kdbx files I share with customers (one file per customer).

    On the biggest one .kdbx file (140KB used under Windows by the customer) if I just open it and save I get à 97KB file. Data is lost.

    The second biggest file I have is 120KB and I have no problem with it, so I'm not convinced that the size is the problem as this is larger than the remaining 97KB.

    Do you have any idea about what could cause this? Used languages in the kdbx files are english and French.

    Obviously I can't share the file, but feel free to ask for more detail if needed.

    Thank you in advance.

  • Paul

    Paul - 2013-09-06

    Is data lost? Maybe the file is compressed better on the system you are using.
    Can you save the file on another computer without losing data?

    cheers, Paul

  • Whoszat

    Whoszat - 2013-09-09


    And first, thank you very much for looking into it.

    Here is what I did: I copied both .kdbx files (140K and 97K) in a Windows XP session and opened them with Keepass, exporting à CSV version of each. Then I copied the .CSV files back under linux and made a diff... the files are the same so it doesn't seem that data has been lost.
    At that point if I'm right it seems that the customer just thought data was lost because of the file's size modification. I'll check with him and let you know if there is something wrong, but it looks like you pointed out what happened.

    Thank you once more for your assistance. :)

    Best regards

    Last edit: Whoszat 2013-09-09
  • Paul

    Paul - 2013-09-09

    Turn off compression to test. Tools > Database Settings > Compression

    cheers, Paul

  • Whoszat

    Whoszat - 2013-09-10


    I haven't got such an option, I just have Tools > Database tools >Database maintenance plus some deleting options.
    Does this come from a plugin?

    Thanks in advance,

  • Paul

    Paul - 2013-09-10

    Sorry, it's File > Database Settings.

    cheers, Paul

  • Whoszat

    Whoszat - 2013-09-10

    Ok so both uncompressed files have the same size, so with this everything seems clear now.

    Thank you very much for your assistance.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks