IE9 has no Window Titles

Help
2011-05-03
2012-11-19
  • David Hague

    David Hague - 2011-05-03

    As I can find no existing threads on this subject, I assume I'm missing something obvious.

    But, as all the titles are on tabs, not on the title bar, Keepass doesn't want to work with IE9.

     
  • Dominik Reichl

    Dominik Reichl - 2011-05-03

    IE9 windows do have titles. IE9 doesn't visually draw the title in its title bar, but it still defines it.

    Some ways to get access to the window title:
    * Hover over the taskbar item; the title is displayed in a tooltip.
    * Start the task manager; the title is shown on the applications tab.
    * Use the window title assistant in KeePass:
    - In KeePass 1.x, open an entry, click the 'Tools' button and choose 'Auto-Type: Select Target Window'.
    - In KeePass 2.x, click the drop-down arrow of the 'Target window' combobox in the auto-type sequence editing dialog.

    Best regards
    Dominik

     
  • David Hague

    David Hague - 2011-05-03

    Thanks, Dreichl.  But that poses a different question  ;-)

    The window title is therefore still the same as before (the title shown in the tab is the same as the old window title, and is the title already listed as the Auto-Type-Window:).

    But Keepass hasn't functioned since IE9 was installed this afternoon.  Any ideas?

     
  • David Hague

    David Hague - 2011-05-03

    That is to say, Auto-Type hasn't functioned.

     
  • David Hague

    David Hague - 2011-05-03

    OK.  I seem to have a solution, though I don't yet know why.

    The title of the Keepass entry was merely descriptive, the Auto-Type window entry was the one that defined the string and started Auto-Type, eg the first word or two followed by a *.  In other words, under IE8 the 'Auto-Type-Window' entry took precedence.

    Under IE9 it doesn't seem to take precedence, and I have had to change the title of the Keepass entry from the merely descriptive to a string matching the Auto-Type-Window string.

    No idea why but that seems to work, though I didn't think it was meant to be that way…..

     
  • David Hague

    David Hague - 2011-05-05

    OK, I now know what was really going on but still don't know why.

    The reason Auto-Type was sometimes working and sometimes not (and that led me to think my tweaking was having an effect) was that I had two instances of IE9 open; the second one must have been opened as a popup from a link in either an email or another website, I can't remember and haven't replicated it.

    Auto-Type works just fine, exactly as it did before I moved to IE9, in the original IE9 window.

    But it didn't work at all in the second instance of IE9 that had been opened.

    I had first tried A-T in the 2nd window and decided it didn't work.  After making a change, eg as in my prev post, I must have used A-T in the original window and thought my change was what had made the difference.

    I've since tried opening a second instance of IE9 and A-T works fine, so there must have been something different about that particular popup window.

     
  • DrDOS

    DrDOS - 2011-11-28

    Hello,
    Has this questioned been answered?  If so, cheers!

     
  • Paul

    Paul - 2011-11-28

    Which question, there are a few here?

    cheers, Paul

     
  • DrDOS

    DrDOS - 2011-11-28

    The concern about IE9 not showing the title bar.   Microsoft sure didn't think this one through did they?  There's probably some registry hack but look at Quero.  Make sure you back up (restore point, backup or whatever makes you feel comfortable) before taking the plunge.  The only piece I don't like is where the Options box appears.  Not a deal breaker but maybe it can be "right"ed. 

    c ya 4 now  Drew

     
  • DrDOS

    DrDOS - 2011-11-28

    -----------------------------Ooops!  Sorry everyone.  Now corrected ---------------------------------------
    The concern about IE9 not showing the title bar.   Microsoft sure didn't think this one through did they?  There's probably some registry hack but look at Quero.  Make sure you back up (restore point, backup or whatever makes you feel comfortable) before taking the plunge.  The only piece I don't like is where the Options box appears.  Not a deal breaker but maybe it can be "right"ed. 

    c ya 4 now  Drew

     
  • DrDOS

    DrDOS - 2012-05-18

    Biiggles,

    Did you ever get this resolved?

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks