Global auto-type in Ubuntu 13.10

  • Tomas Mrozek

    Tomas Mrozek - 2014-01-27

    I have KeePass 2.23 running under mono in Ubuntu 13.10. It works very well but I cannot get the auto-type to work. The shortcut is correct because if I leave out "--auto-type", KeePass is run with Ctrl+Alt+A. I suspect that the malfunctioning has something to do with the xdotools (I tried one from the Ubuntu repository and I also tried to install different version manually).

    Is there some way to debug this so that I find out what the problem is?

  • Paul

    Paul - 2014-01-27

    This page has details of the xdotools version required.
    After that I don't know what to suggest.

    cheers, Paul

  • Tomas Mrozek

    Tomas Mrozek - 2014-01-28

    Thanks Paul. I know of that requirement and both of the xdotools I tried have higher version than the one stated. I'm not sure that xdotools are at fault but I currently cannot think of anything else and I don't now how to find out.

  • Paul

    Paul - 2014-01-28

    You could try the Ubuntu forum.

    cheers, Paul

  • Tomas Mrozek

    Tomas Mrozek - 2014-01-30

    Thanks Dominik. I'll give it a try.

    Just in case it doesn't work, is there some debug mode with logging I could turn KeePass into so that I can see what's going on? Is there a way to know how KeePass is calling xdotool so that I can test it myself?

  • Tomas Mrozek

    Tomas Mrozek - 2014-01-31

    I've tried the new version and it hasn't changed anything for me so something else is the problem.

  • Paul

    Paul - 2014-01-31

    Do you have another package installed that works with the clipboard / keyboard?

    cheers, Paul

  • Dominik Reichl

    Dominik Reichl - 2014-01-31

    If you right-click onto a KeePass entry and choose 'Perform Auto-Type', does it send anything?

    If you run KeePass with a terminal (e.g. right-click on KeePass.exe and open it with 'Mono Runtime (Terminal)', do you see any output produced during the auto-type process?

    Best regards,


Log in to post a comment.