Password field 'smurfs'

Help
twhanson1
2013-02-11
2013-02-13
1 2 > >> (Page 1 of 2)
  • twhanson1

    twhanson1 - 2013-02-11

    I have a logon display (https://www.regions.com/personal_banking.rf) that first appears as follows:
    My User ID field is already filled in.
    The cursor is blinking in next field which is the password field.
    There is a pre-checked check-box (Remember online ID) that follows.
    Lastly, there is the login button.

    My override default sequence is {TAB}{ENTER}{PASSWORD}{ENTER}

    When I execute auto-type (ctl-Alt-a), the password field turns from white to blue. Does not logon.

    What would you suggest?

     
  • wellread1

    wellread1 - 2013-02-11

    Remove the first {TAB}{ENTER}

     
    Last edit: wellread1 2013-02-11
  • twhanson1

    twhanson1 - 2013-02-11

    Wellread1, I actually am using just {PASSWORD}{ENTER}. I tried so many things, I made a mistake and copied my last desperate attempt. I apologize.

     
  • Paul

    Paul - 2013-02-11

    That looks OK from my testing of that site.
    As there is quite a bit of javascript in the page try adding some delays.
    {DELAY 100}{PASSWORD}{DELAY 100}{ENTER}

    cheers, Paul

     
  • twhanson1

    twhanson1 - 2013-02-11

    Thanks Paul. I tried:{DELAY 100}{PASSWORD}{DELAY 100}, then {ENTER}{DELAY 1000}{PASSWORD}{DELAY 1000}{ENTER}. Neither worked. Same situation i.e., the password field turned from white to blue with cursor still blinking in that field.

     
  • twhanson1

    twhanson1 - 2013-02-11

    Paul, I just tried {DELAY 10000}{PASSWORD}{DELAY 10000}{ENTER}. Same results.

     
  • wellread1

    wellread1 - 2013-02-11

    I tested using KeePass 2.21 with Firefox 18.0.02 on Windows Home Premium x64. I don't have an account at Regions but I was able to obtain the "Having Trouble Accessing Your Account?" page repeatedly using the very basic sequence {USERNAME}{TAB}{PASSWORD}{ENTER}. This is a good indication that the site attempted to verify the login credentials that were entered.

    Things you can try

    1. Reboot your computer.
    2. Turn off TCATO for the entry if you have it enabled. (Edit Entry Window->Auto-type(tab), uncheck: Two-channel auto-type obfuscation)
    3. Remove the final {ENTER} and verify that after the auto-type completes, the password was entered in the correct webpage field and the cursor is at the end of the password. Press Enter manually and verify that the username and password are accepted.
    4. Make a new KeePass entry (to eliminate the possibility that the current entry contains an invisible control character or contains some other unsuspected typo)
     
  • wellread1

    wellread1 - 2013-02-11

    Make sure you have not been locked out of your account by logging in manually.

     
  • twhanson1

    twhanson1 - 2013-02-11

    I just logged in manually, so that doesn't seem to be the case Wellread1. It is curious that the password entry field changes color, just as it does when I enter the first character of my password manually.

     
  • wellread1

    wellread1 - 2013-02-11

    I have no idea what the color change on the website means. I don't observe it and it may not be relevant. It isn't related to KeePass if it happens during a manual login.

     
  • twhanson1

    twhanson1 - 2013-02-11

    The other curiosity is how my login ID became pre-entered. I can't find anything on the Region.com website or in my account that allows for this option. Ever heard of such a thing? If I could just get rid of my login ID, maybe KeePass would work.

     
  • twhanson1

    twhanson1 - 2013-02-11

    I unchecked the 'Remember Online ID' box, and logged in manually. Then I logged out and logged back in. This time, both Login ID and password fields were blank with the cursor blinking inside the login ID box. I changed my KeePass override default sequence to: {UserName}{ENTER}{PASSWORD}{ENTER}{ENTER}{ENTER}. This time the login ID box (instead of the password box) turned from white to blue.

     
  • twhanson1

    twhanson1 - 2013-02-12
    1. Reboot your computer. No help with this step.

    On to #2. What's TCATO?

     
  • twhanson1

    twhanson1 - 2013-02-12

    I see, "Two-Channel Auto-Type Obfuscation" is TCATO. Anyway, I unchecked that: No change.

     
  • twhanson1

    twhanson1 - 2013-02-12

    3: I edited, "{UserName}{ENTER}{PASSWORD}". The login page Online ID field contained a blinking cursor when it came up. After executing KeePass, the blinking cursor was still in the ID box. Totally ignored KeePass.

     
    Last edit: twhanson1 2013-02-12
  • twhanson1

    twhanson1 - 2013-02-12

    OK, I have no idea where the giant font came from.

     
  • twhanson1

    twhanson1 - 2013-02-12

    4 worked! I'm going to try that with some other logins that I've been having trouble with.

    Thanks for staying with me.

     
  • twhanson1

    twhanson1 - 2013-02-12

    Spoke too soon. I didn't work when I tried it again. So I logged in manually, logged out, logged back in. Still didn't work.

     
  • twhanson1

    twhanson1 - 2013-02-12

    You're going to flip when you read this. I followed your suggestion and created a new entry called "Regions", so as not to conflict with the troublesome entry, "Regions Bank". This worked fine. So I deleted the Regions Bank entry and changed my working entry name from Regions to Regions Bank. That's when it stopped working again.

    Out of desperation, I changed the name back to Regions, and it's worked fine since. The only difference was the tittle i.e., "Regions" works; "Regions Bank" doesn't. What do you figure?

     
  • twhanson1

    twhanson1 - 2013-02-12

    This is too surreal. I was having the same problem with an entry called "Fidelity Bank". I just tried it again to make sure that it didn't magically cure itself overnight. Nope, still screwed up. So I changed the name to "Fidelity" and voila! It works. I won't use the word Bank in a title until I find out more.

     
  • twhanson1

    twhanson1 - 2013-02-12

    I just tried (twice) logging onto a KeePass Entry I called "Electric Utilities". This time I simply changed the name to "Electric", and it worked. A provisional conclusion might be that KeePass doesn't handle multiple word titles.

     
  • wellread1

    wellread1 - 2013-02-12

    Here's what's going on. When you use Global Auto-type, KeePass looks at the Window Title in the browser, and searches KeePass for an entry whose Title is a substring of the Window Title. If it finds a match, it types the default auto-type sequence.

    On your the Regions Bank website, the full Window Title in Firefox is "Regions | Personal Banking | Banking Solutions - Mozilla Firefox". In this example, an entry with a Title such as "Regions" or "Personal Banking" or "Regions | Personal Banking" (without the quotes) would all have matched, but "Regions Bank" (without the quotes) is not a substring of the Window Title so it will not work.

    It appears that you are also using the custom auto-type feature. The same matching rule applies. However, in a custom auto-type if the Target Window is a substring of the Window Title you must include the appropriate wild cards to obtain a match (e.g. "*Regions*" or "*Regions | Personal Banking*" (without the quotes))

    See Global Auto-Type Help for additional details.

     
  • twhanson1

    twhanson1 - 2013-02-12

    Thanks Wellread1. I'll apply that information to some of my other stubborn logins.

     
  • twhanson1

    twhanson1 - 2013-02-12

    Not completely sure I understand though. For example the login page, "https://www.nespower.com/login/login.aspx" would not work with a title of "Electric Utilities". Yet it works fine when the title is shortened to "Electric". And nowhere in the URL is does the word "Electric" or "Utilities" appear.

     
1 2 > >> (Page 1 of 2)

Log in to post a comment.