Sandboxie and Keepass

Help
userxyz
2013-07-12
2013-07-13
  • userxyz

    userxyz - 2013-07-12

    Normally, when I click on the URL column of an entry in Keepass, Internet Explorer will open that entry's site in a new tab of the browser. However, when I do it when IE is running inside an instance of Sandboxie, instead of a new tab opening I get a new instance of IE outside of Sandboxie. That is undesirable, and I was wondering whether anyone has worked out a solution?

     
  • userxyz

    userxyz - 2013-07-12

    No, I had not seen it. Thanks for pointing it out. Even so, from what I can make of it, looks to me like it would result in having the browser open in Sandboxie but not in a new tab. Instead, it would open another instance of the browser. That is not much better than the current problem. Also, I noticed the comment in that dialogue about how he was blaming the problem on Windows itself. However, I can't really accept that argument because it was working correctly in Keepass before a previous upgrade to the program removed this functionality. I would prefer a bonafide solution. Again, thanks.

     
    Last edit: userxyz 2013-07-12
  • wellread1

    wellread1 - 2013-07-12

    I can't really accept that argument because it was working correctly in Keepass before a previous upgrade to the program removed this functionality.

    Which KeePass version transition did this occur between? When you upgraded did you retain the settings?

    While I don't use IE much, it looks like there are settings in IE that control whether links from other programs open in a new Window or Tab e.g. Tools>Internet options>General(tab)>Tabs(button).

     
    Last edit: wellread1 2013-07-12
  • Paul

    Paul - 2013-07-13

    Sandboxie is designed to limit interaction with your OS and other applications, so this is reasonable behaviour. The only work around is to copy the URL and paste it into IE.

    cheers, Paul

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks