Autotype suddenly started going very slowly

Help
2010-12-21
2012-12-11
  • citizen_snips

    citizen_snips - 2010-12-21

    I have been using Keepass for a few weeks now and just yesterday I noticed that autotype started entering in text much slower than usual.  It has been doing this on every website I have tried it on.  Does anyone know what might have caused this?  I didn't add any {DELAY} statements to any of my entries.

     
  • Paul

    Paul - 2010-12-21

    Maybe it's your browser? Try it in Notepad.

    cheers, Paul

     
  • citizen_snips

    citizen_snips - 2010-12-23

    I tried it in Notepad and it types at the exact same speed as in IE.  What else could it be?  I could swear it was typing much faster just a few days ago.

     
  • citizen_snips

    citizen_snips - 2010-12-23

    Also are there settings that I'm not seeing in the main windows?  It looks like when I use autotype on gmail or facebook, Keepass types a '1', backspaces it, and then types {USERNAME}{TAB}{PASSWORD}{ENTER}, even though my autotype settings are only  {USERNAME}{TAB}{PASSWORD}{ENTER}.  Is that correct?  Are there characters and settings that are added by default?  If so, is the typing speed one of them?

    I would have just added this to my last post, but there doesn't seem to be a way to edit existing posts.

     
  • Paul

    Paul - 2010-12-23

    1. Close KeePass
    2. Copy KeePass.exe to a temporary directory.
    3. Open KeePass from the temporary directory and create a new database.
    4. Test Auto-Type in Notepad.
    This will eliminate any settings from the existing KeePass.

    cheers, Paul

     
  • Dominik Reichl

    Dominik Reichl - 2010-12-23

    The 1-Backspace prefix that you've observed is caused by the option "Prepend special initialization sequence for Internet Explorer windows" (in 'Tools' -> 'Options'). I highly recommend leaving this option enabled, otherwise you might run into menu focusing issues.

    Best regards
    Dominik

     
  • citizen_snips

    citizen_snips - 2010-12-27

    1. Close KeePass
    2. Copy KeePass.exe to a temporary directory.
    3. Open KeePass from the temporary directory and create a new database.
    4. Test Auto-Type in Notepad.
    This will eliminate any settings from the existing KeePass.

    cheers, Paul

    I tried that, and it really doesn't seem to be going any faster than before.  What else could it be?  Is there any way to manually speed it up?  I could have sworn it was typing faster when I first started using it.

     
  • Paul

    Paul - 2010-12-27

    May be your machine. Try it on another machine.

    cheers, Paul

     
  • citizen_snips

    citizen_snips - 2010-12-28

    May be your machine. Try it on another machine.

    cheers, Paul

    OK, I tried it on another computer and it definitely seems to be a problem with my PC.  I created a test key that would type in {USERNAME}{ENTER}{PASSWORD}{ENTER} into notepad.  {USERNAME} was my email address, and {PASSWORD} was a random 100 character password using everything except spaces.

    On my PC, it took about 5 seconds to autotype.  On another computer, it took only 1.6-1.7s to autotype.  I even reinstalled Keepass on the computer that types slowly and it didn't change anything.  For the record, my PC is running Vista Business 64-bit and the other computer was running XP Pro 32-bit, but they both used Keepass v2.13.

    What's even stranger is that on the computer that autotypes slowly, if I run the notepad test over and over, sometimes it will autotype just as fast as the other computer (and just as fast as it used to when I first installed Keepass).  It seems to be completely random, however.  Normally it autotypes very slowly, and I can't figure out what's causing it.

    Any  ideas?  Does the physical keyboard I am using make any difference?  It seems like it would have to be some setting in windows or a hardware issue.

     
  • Paul

    Paul - 2010-12-28

    It will not be KeePass if the same version works OK on another computer.
    Try the RCD Auto-Type plug-in and Auto-Type into Internet Explorer. If this fixes the problem it is likely to be a problem with .NET. Try repairing the .NET installation.

    cheers, Paul

     
  • citizen_snips

    citizen_snips - 2010-12-29

    2010-12-28 03:08:08 EST
    It will not be KeePass if the same version works OK on another computer.
    Try the RCD Auto-Type plug-in and Auto-Type into Internet Explorer. If this fixes the problem it is likely to be a problem with .NET. Try repairing the .NET installation.

    cheers, Paul

    First of all, I tried the RDC plugin.  With the default settings, autotype typed very fast in IE8, but usually didn't type the correct password sequence.  I'm not sure what was going wrong there.  If I unchecked the iexplore.exe box, then the autotype went back to its slow speed, but the characters typed were correct.

    Second, I repaired my .NET Framework installation (3.5 SP1) and rebooted, but that didn't change anything.

    Do you have any other ideas?  Obviously Keepass will still work with Autotype being slower than normal, but it would be nice to have it type as fast as it possibly can.

     
  • sors

    sors - 2012-12-11

    I also experience different auto-type speeds (KeePass 2) on the same computer.

    The fast one takes about 1 second and the slow one takes 2-3 seconds.
    It happens seemingly randomly (perhaps related to other processes/programs running...).

     
  • Paul

    Paul - 2012-12-11

    It is likely to be something on your machine, but there is no downside as long as Auto-Type still works.

    cheer, Paul

     

Log in to post a comment.