Autotype - shows more than one option

Help
steelej
2012-11-18
2012-11-20
  • steelej

    steelej - 2012-11-18

    I am getting some strange results where Autotype is eelcting either the wrong entry or offering two entries where the selection should be unique.

    I have an entry for a site for the Topfield forum

    The title shows in IE and Google broswers as

    Toppy.org.uk ~ View Topic
    Toppy.org.uk ~ Log in

    When I use CTRL+Shift+A to enter the autotype  I get offered

    Google
    Toppy.org

    I am unable to work out why Google is offered as a choice.

    Note that the problem appears to be with the google entry as this is offered in other cases as well

    The Google Title/URL are

    Google
    https://accounts.google.com/ManageAccount?hl=en

    The toppy Title/URL as configured into Keepass are

    Toppy.org
    http://forum.toppy.org.uk/forum/index.php

    When I go to the google page I the autotype sequence works as expected

     
  • Paul

    Paul - 2012-11-18

    I would expect the Google entry to match most things if you are running "Google Chrome".
    If it is only the Google entry that is a problem you need to look at what Title you use and any Auto-Type target settings.

    cheers, Paul

     
  • steelej

    steelej - 2012-11-18

    I do have an entry that contains my  Google credentials. I also use chrome as my default browser for historical reasons, no longer valid.

    I am not clear why the term Google in the Title field will match anything opened by the Chrome browser and how can I stop it while still being able to log into Google when I need to.

    There seems to more to the "Title" field that I first realised.

     
  • steelej

    steelej - 2012-11-20

    Paul's post was lost!

    "Possibly. Edit an entry and select Auto-Type.
    Click Add and use the Target window drop down to view the window titles.

    cheers, Paul
    "
    That explains it!!

    The title displayed iin the browser is
    MyAccount

    Using Paul's trick to see the title returned this is what I get
    MyAccount - Google Chrome

    Windows Explorer adds
    - Windows Internet Explorer

    Instead of
    - Google Chrome

    The next question therefore:

    How do I eliminate the suffix identifying the browser from any matches in autotype?

     
  • Paul

    Paul - 2012-11-20

    Change the title of the KeePass entry that is for Google, make it something like "Google Account". Add a target window filter under Advanced so it still works in Google.

    cheers, Paul

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks