Disable auto-type for multiple entries

Help
shellfire3
2012-03-13
2012-11-19
  • shellfire3

    shellfire3 - 2012-03-13

    Is there any way to disable auto-type function for multiple entries. I try with group options but that do not uncheck auto-type in specific entries but only disable entire group. I missing something?

     
  • wellread1

    wellread1 - 2012-03-13

    To disable auto-type for an individual entry: Edit the entry, select the auto-type tab, uncheck "Enable auto-type for this entry"

    -wellread1

     
  • shellfire3

    shellfire3 - 2012-03-13

    I know that. But how to change more than one item at once? I have more than 200+ items to change, so it is kind of pointless to do it manually.

     
  • Paul

    Paul - 2012-03-13

    If you edit the group and set the override to space and backspace this should work.

    cheers, Paul

     
  • wellread1

    wellread1 - 2012-03-13

    There is no easy way to disable auto-type for multiple, arbitrarily selected entries.  You can disable individual entries as I described. You can disable auto-type in an entire group by selecting "Disabled" in the Behaviour tab of the "edit group" dialog. 

    A possible workaround that should enable you to disable the individual auto-type setting of a large number of entries in different groups would be as follows (I have not fully tested this so try this on a copy of your database):

    1. for each group that contains entries that you want to disable the auto-type, create a sub group.
    2. Move the entries that you need to disable from the parent group to the sub group
    3. export the sub group as XML file
    4. Open the XML file with a text editor, and search and replace, changing every occurrence of <Enabled>True</Enabled> to <Enabled>False</Enabled>
    5. Import the modified group into your database
    6. Move the entries back into the parent group & delete any obsolete or empty groups.

    Note: It appears that the <Enabled>True</Enabled> string is unique and applies only to the entry's auto-type property.  However, you should exercise due care to make sure that this is true.

    -wellread1

     
  • shellfire3

    shellfire3 - 2012-03-14

    Great idea! I try that wellread1 and it works perfectly. I just have to check if attachments are also exported into xml and than back to keepass.

    It would be great it that function would be part of keepass. I think that auto-type function should be disabled my default.  

     
  • Kev

    Kev - 2012-03-14

    Hi,

    If you are using version 2 and all the entries are in the same group, try this:

    Right click the group -> Edit Group -> Behavior -> Auto-Type for entries in this group -> Disabled

     
  • shellfire3

    shellfire3 - 2012-03-16

    That works if you wish to disable entire group. But if you need only individual entries to be disabled or enabled that will not work. In my case I have to disable all and then enable only few of them.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks