Help save net neutrality! Learn more.
Close

Auto-type uses old password

Help
Jessica
2013-12-07
2013-12-08
  • Jessica

    Jessica - 2013-12-07

    When I use the auto-type feature it uses my old password.

    Previously, I had no issues using auto-type. I changed passwords at a few sites and updated them in the KeePass entries. However, the auto-type still uses my old password. When I click copy password from the entry within KeePass, it will copy my new password. How can I fix this? I don't want to copy my passwords every time I use them.

     
  • Paul

    Paul - 2013-12-07

    You must still have an entry with the old password in the database. How did you update the entry in KeePass?

    cheers, Paul

     
  • Jessica

    Jessica - 2013-12-07

    Within the Edit entry when you right click it

     
  • Paul

    Paul - 2013-12-08

    Then the new password should be in that entry, is it?
    Search KeePass for part of the old password and tell us where it's found.

    cheers, Paul

     
  • Jessica

    Jessica - 2013-12-08

    The KeePass entry has the new password. When I do a search for the old password, it doesn't pull the entry at all.

    In the "History" of the entry it shows the old password. I tried deleting that and restarting KeePass but still no luck.

    Also tried uninstalling / reinstalling KeePass which did not work. I suppose that was wishful thinking more than anything

     
    Last edit: Jessica 2013-12-08
  • wellread1

    wellread1 - 2013-12-08
    1. What have you done to establish that auto-type is typing the old password as opposed to some other wrong password? (Passwords are typically obscured when they are entered in a password field.)

    2. Verify that the expected entry is responsible for the auto-type: open the entry for editing; navigate to the auto-type tab; uncheck "Enable auto-type for this entry"; close the entry and retry auto-type. Auto-type should stop working for the problem site. If it doesn't that means that KeePass auto-type is using a different entry than expected.

     
    Last edit: wellread1 2013-12-08
  • Jessica

    Jessica - 2013-12-08
    1. I used Ctrl + Alt + A in my navigation bar. I do have mine set to show the password rather than asterisks.

    2. You were right - it was pulling another entry. I'm not sure which as none of them (seemed to be) mis-configured. I'm new to this (so I apologize if I'm asking obvious questions), has anyone had issues saving their database directly to Google Drive?

    I ended up deleting my database and started over again. All is well now. Thank you

     
    Last edit: Jessica 2013-12-08
  • wellread1

    wellread1 - 2013-12-08

    In its default configuration, KeePass auto-type works by matching KeePass entry titles against Window Titles. Browser Window Titles generally do not include the webpage URL. Additionally current browser versions include a suffix as part of the Window Title that doesn't display as part of the browser Tab Title.

    For example for the test webpage http://keepass.info/help/kb/testform.html, the complete Window Title in Chrome is "Test Form - KeePass - Google Chrome", but the browser tab title displayed is "Test Form - KeePass", and the URL does not appear anywhere in the Window Title. For this case, any KeePass entries called "Test", "KeePass", "Google", "Chrome", or "Test Form - KeePass - Google Chrome" would match the Window Title. If there were multiple matches, KeePass will display a selection dialog, but if there is just one match KeePass will simply auto-type. You can see the complete Window Title of all open windows as follows:

    1. open an Entry for editing;
    2. select the Auto-Type tab:
    3. Press the Add button and examine the dropdown list of the Target Window field.

    You should name your entries to minimize duplicate matches. You may want to review the KeePass auto-type help page for more information. Also there are some browser plugins and other types of plugins that can help reduce the frequency of duplicate matches.

     

Log in to post a comment.