Invalid/Wrong Key

Help
2005-03-07
2012-11-19
  • Nobody/Anonymous

    I have been using Keepass 0.98b for the last few weeks without any problems. Today I loaded keepass to retrieve a password when it informed me "An error occured! Error code: 0x00000004 Invalid/wrong key".  Which usually indicates I have entered an incorrect key to access my password database.  I have had multiple attempts and know that the password i am using is correct.

    After restarting, reloading the program, duplicating my database, restoring it from backups.  I managed to gain access.  When I closed down keepass and tried again later I hit the same program again with invalid/wrong key.

    I suspect the keepass program is not at fault and that it is Windows XP itself or some program running resident that is either changing the keymapping, unicode or something similar.

    Any help would be appreciated as I can see from reading the forums I am not the only one with this problem.  It appears to be an intermittent fault though which will make tracking down the cause that much harder.

     
    • Paul

      Paul - 2005-03-07

      Have you got a stuck Ctrl or Alt key. Seems reasonably common in windoze. It may coincide with KeePass turning off Ctrl before auto typing data.

      cheers, Paul

       
    • Nobody/Anonymous

      I checked that and no apparent stuck keys.  I installed keepass on my laptop and still i cannot access the database.

      In my mind I get the feeling that when the password was originally set the computer was in a particular state, now its reverted to a normal state and does not recognize the keyboard mapping (or something similar).

      My O/S is in NTFS while my password database is stored in FAT 32, also my Microsoft Keyboard has one of those Function buttons that enable/disable the F keys.

      I am not sure if that has anything to do with it but I feel that there is some program/function resident causing this.  I do not think this is only on my computer as a number of people have mentioned similar problems in this forum.

       
    • Paul

      Paul - 2005-03-08

      Click on the button to show the password (instead of asterisks) and type the password in, then try it with Caps Lock on. Good Luck!

      cheers, Paul

       
    • Nobody/Anonymous

      I pressed the button to display the password, entered the password.  Tried it, invalid.

      I pressed the button to display the password, pressed capslock, tried it.  Invalid.

      Is that what you mean ?

       
    • Nobody/Anonymous

      Fixed the problem, I had spyware on my computer.  It was some form of keylogger.

       
    • Paul

      Paul - 2005-03-10

      Now you know why you need keyfile and password security.

      cheers, Paul

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks