Keepass is still crashing when .NET 4 is installed by Microsoft

Help
fabads
2013-05-27
2013-06-01
  • fabads

    fabads - 2013-05-27

    Hello,

    I reopen a topic because each time Microsoft installs .NET4 (e.g. Ms Office 2013 in my case), once the computers reboots, Keepass 2.22 crashes at start up and even if I reinstall, it fails to start.
    Is there any release planned in order to be compatible with .NET 4 ?
    It seems to work if I uninstall "Microsoft .NET Framework 4 Client Profile"

    Regards.

    Fabrice

     
  • John L.

    John L. - 2013-05-27

    This will not be overly helpful, just a comment that, with Windows 7 Home Premium, I have KeePass 2.2.2 and Microsoft .NET Framework 4 Client Profile both running with out any crashing. This makes me suspect that there is another problem on your computer causing the crashes; of course, I have no idea as to what that problem might be, nor how to fix it.

     
  • fabads

    fabads - 2013-05-28

    Strange ! In my case uninstalling .NET 4 is sufficient but is now required by other applications. I tried to re install again but same issue.

    Here is the details (but not sure it helps anyone !):

    ignature du problème :
    Nom d’événement de problème: APPCRASH
    Nom de l’application: KeePass.exe
    Version de l’application: 2.22.0.0
    Horodatage de l’application: 515eac36
    Nom du module par défaut: KERNELBASE.dll
    Version du module par défaut: 6.1.7601.18015
    Horodateur du module par défaut: 50b8479b
    Code de l’exception: e0434352
    Décalage de l’exception: 0000000000009e5d
    Version du système: 6.1.7601.2.1.0.256.1
    Identificateur de paramètres régionaux: 1036
    Information supplémentaire n° 1: 7ccb
    Information supplémentaire n° 2: 7ccb2fa98342573c8a26d5624a3b51e6
    Information supplémentaire n° 3: 0a59
    Information supplémentaire n° 4: 0a5969b53d8e6be72c5075960fba0b42

    Regards.

     
  • Dominik Reichl

    Dominik Reichl - 2013-05-28

    It's not a KeePass problem; your .NET installation is broken.

    There seem to be more .NET applications having a similar issue like yours. You could try:
    - Install http://www.microsoft.com/en-us/download/details.aspx?id=5555
    - Run http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    For one user it turned out that Windows Installer was broken due to a failed Windows update, thus resulting in the .NET installation being corrupt. In this case only a reinstallation of Windows helped.
    http://social.msdn.microsoft.com/Forums/en-US/netfxsetup/thread/5e9877d0-9dc4-45dd-b68a-a239699a7181

    Best regards,
    Dominik

     
    • Wisewiz

      Wisewiz - 2013-05-30

      Is it possible that your .NET 4 is choked? I've had trouble on several machines after .NET 4 installation or upgrades, and I've found it worthwhile to run the NGEN cure. Can't hurt; might help.

      Elevated Command Prompt, cd to C:\Windows\Microsoft.NET\Framework64\v4.0.30319>, then type NGEN executequeueditems at the prompt and Enter. May take up to ten minutes to finish running, depending on the speed of the machine. There will be lines in the output that suggest that NGEN is failing to find anything, but then it kicks on again and compiles and compiles and compiles. It's finished when it returns to the prompt and blinks. Do nothing at all on the computer while NGEN runs. Then just Exit and reboot the machine.

      I've seen machines that were crashing and/or taking five minutes to boot after a .NET installation or upgrade suddenly purring again after an NGEN executequeueditems cleanup and reboot.

      Wisewiz

       
      Last edit: Wisewiz 2013-05-30
  • fabads

    fabads - 2013-06-01

    Hello Dominik,
    Hello Wisewiz,

    I first tried the proposals of Dominik:
    - Re install Microsoft Visual C++ 2010 Redistributable Package (took the last release for my x64 machine) --> No effect on Keepass

    • Then I tried to run .NET Framework Setup Verification Tool. When I select the .NET 4 in the list, it starts checking ... then crashes as Keepass !

    • I tried to run the Microsoft .NET Framework Repair Tool. It says:
      Reregister Windows Installer service
      Unregisters and re-registers the Windows Installer service using MsiExec.exe. Applicable regardless of the diagnosis results.

    Restart Windows Installer service
    Stops and restarts the Windows Installer service. Applicable regardless of the diagnosis results.

    I applied the suggested changes, then the tools recommended to reinstall .NET Framework. What I did (took the opportunity to install release 4.5) but unfortunately, not better result

    • I tried to run NGEN executequeueditems. Before installing .NET4.5 it said "All compilation targets are up to date.". After installing 4.5, it compiling "something". After reboot, I tried keepass with no success !

    Regards.

    Fabrice

     
  • fabads

    fabads - 2013-06-01

    Update of my last post: As I said, after installing .NET 4.5, Keepass was crashing again. But in the mean time, Windows detected new updates to install (updates concerning .NET 4.5). After install, Keepass seems to start again !!!!
    For how long ?!
    In any case, thanks to all of you who take time to provide support.

    Fabrice

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks