Auto-Type not working with DevExpress

Help
Killergege
2014-04-02
2014-04-03
  • Killergege

    Killergege - 2014-04-02

    I just noticed that Auto-Type is not working with the DevExpress login form in their installer (installer downloaded from https://www.devexpress.com/).

    I tried all methods in the documentation :
    - Configure the Entry by adding the installer window in the specific windows list, focus the form and type CTRL+ALT+A, nothing happens
    - Select the entry and choose "Perform Auto-Type" in the context menu, the focus switches to the DevExpress installer window and nothing happens.
    - Select the entry and type CTRL+V, the focus switches to the installer window and nothing happens.

    This is not a critical issue as I still can copy/paste, but I really love the auto-type feature and what is strange is that it works well otherwise (with forms in Chrome, forms in custom apps...), using the "Perform auto-type" menu item with Notepad works well too.

    Thanks.

    I don't know what to do to troubleshoot the issue and give you more information.

    (Windows 7, Keepass 2.25, DevExpress 13.2.8 installer)

     
    Last edit: Killergege 2014-04-02
  • Killergege

    Killergege - 2014-04-02

    Hum... If I use CTRL+ALT+A and manually switch focus to notepad, the end of the password is typed, so I guess that Keepass is sending the user/password to the DevExpress window but it doesn't write in the fields (although the textbox is focused)...

    Feature request : display a tray notification when auto-type global shortcut is detected, this is not the first time I'm wondering if I properly typed the shortcut as it seems that nothing happens when no match is found.

     
    Last edit: Killergege 2014-04-02
  • Paul

    Paul - 2014-04-02

    Are you required to run the installer and login every time you want to use the app or is it a once off when loading a new version?

    cheers, Paul

     
  • Killergege

    Killergege - 2014-04-02

    No, it's just when installing a new version.
    That's why it's not really critical... Just strange.

     
  • wellread1

    wellread1 - 2014-04-02

    There are some dialogs that seem able to prevent auto-type. A notable example is the 'User Account Control' dialog, even when Secure Desktop is disabled.

    Feature request : display a tray notification when auto-type global shortcut is detected, this is not the first time I'm wondering if I properly typed the shortcut as it seems that nothing happens when no match is found.

    You can temporarily add the {PICKCHARS} placeholder to an auto-type as a diagnostic. It will produce a popup dialog when the the sequence containing the placeholder is executed, and type the password if OK is pressed in response to the PICKCHARS dialog.

    Example: In the case of the 'User Access Control' mentioned previously, if the{PICKCHARS} placeholder is in the sequence, the PICKCHARS dialog is displayed but nothing is typed when OK is pressed, demonstrating that the auto-type sequence executed but the dialog did not receive the input. The same sequence, when targeted to Notepad types the password if OK is pressed.

    Sample diagnostic Auto-Type sequences:

    {PASSWORD}{PICKCHARS}{ENTER}{C: Will type the Password PLUS the selected letters when OK is pressed}

    {PICKCHARS}{ENTER}{C: Will type the selected letters when OK is pressed}

     
    Last edit: wellread1 2014-04-02
  • Paul

    Paul - 2014-04-03

    If it's a permission thing you could try running KeePass as admin - right click on KeePass.exe and select "Run as administrator".

    cheers, Paul

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks