Linux (Mint 15) - how to get KeePass to autostart

  • spacewalker

    spacewalker - 2013-11-07

    I'm trying out Linux Mint 15 in a vm, and have KeePass installed. It works fine however I can not get it to be added to the list of programs that autostart in the autostart application.

    If in the autostart application I browse to the KeePass.exe file, which works if clicked in Dolphin, I get an error saying it doesn't exist or something from the autostart dialog when I try to add it.

    I'm supposing I need to actually create a script related to mono or some such, but my internet and forum searches have come up blank so far.

    I really like having KeePass autostart on my Windows system and I'd like the same in Linux.

    Any suggestions or links to someplace that details how to do this?

    I'm assuming this is fairly basic but I haven't figured it out yet.


  • David Lechner

    David Lechner - 2013-11-07

    Option 1: Install the Ubuntu package version of KeePass if you have not already.

    sudo apt-get install keepass2

    Or if you want the latest version...

    sudo add-apt-repository ppa:jtaylor/keepass
    sudo apt-get update
    sudo apt-get install keepass2

    The startup script is then found at /usr/bin/keepass2.

    Option 2: Create your own startup script.

    As you have discovered, you cannot directly run .exe files. You have to call it with mono. So, for example, you could create a script like this to start KeePass with a specific database.

    /usr/bin/mono /home/me/bin/keepass2/KeePass.exe /home/bin/MyDatabase.kdbx
    • spacewalker

      spacewalker - 2013-11-08

      Thanks David. I added the repository, then used the software manager to install it. (Originally I had installed the files from KeePass itself).

      And after realizing another goof to setup Global-Auto-Type I now have that working in addition to getting KeePass to auto-start on boot up. Thanks!


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks