Linux : autotype cannot see the window

  • Philj34

    Philj34 - 2014-07-12

    I'm using UbuntuStudio 14.04 with KeePass2 2.25 (packaged with UbuntuStudio 14.04). Generally, I find auto-type with or without TCATO works fine just as I did it in Windows7 before moving to linux. However, I cannot get auto-type to work with gpg in Thunderbird. I don't know if this is down to Thunderbird or enigmail or KeePass2 or UbuntuStudio.

    When sending gpg signed or encrypted emails with Thunderbird, pinentry opens a dialogue asking for my passphrase for my private key. The name of the pinentry window is 'pinentry-gtk-2'

    When I open KeePass auto-type tab and click to add new target window, the drop down list does not include pinentry-gtk-2. There are typically six or seven other windows listed but not the one I need.

    Since moving to linux, I have had several problems with KeePass2 connected with use of inappropriate fonts - fonts specified in keepass xml file which are not in my linux distribution; fonts that are so small it renders the keepass stuff difficult to read; password generator that doesn't appear to permit focus to the number of character field but in reality the first 3 digits are hidden by up/down arrows.

    It looks like font selection has at least some impact here too because the drop down target window list sometimes displays an odd half line at the bottom - and it has no scroll button. But it doesn't appear to be the heart of this problem.

    I've tried manually creating an auto-type entry called 'pinentry-gtk-2' but that doesn't solve the problem either.

    Even if I copy the passphrase to the clipboard, I cannot paste it into the pinentry-gtk-2 dialogue. The only way to get the message sent is to type the passphrase into the pinentry window by hand.

    This case was something that worked so smoothly over years in WindowsXP and 7, with various versions of KeePass2 and various versions of Thunderbird and enigmail. Does anyone have an explanation and solution, please ?

  • Paul

    Paul - 2014-07-13

    When the pinentry window appears, open KeePass, right click on the entry and select "Perform Auto-Type".

    Fonts and screen drawing are handled (badly) by mono. There are a few workarounds in KeePass for some of the mono problems but not all - not all are problems on all Linus systems either.

    cheers, Paul

  • Philj34

    Philj34 - 2014-07-14

    Thanks Paul. The right click and 'perform auto-type' does at least open some contact between KeePass2 and the pinentry window but each time the pass phrase gets corrupted and the send fails.

    So I disabled TCATO for this KeePass2 entry and then it works ok and the send proceeds.

    Using the keyboard shortcut that I defined for autotype (following instructions on the KeePass2 webpages) works pretty well for all the web pages I've tried so far since converting to linux - and with using TCATO too.

    But not working for the pinentry window ? That I find a little strange.

    So I have a workaround for the moment but it would be good to get to the bottom of this problem.

  • Paul

    Paul - 2014-07-14

    As this is a Linux system I can't really advise, or test.
    If it works in Windows it's likely to be a mono issue, so testing on another machine would be useful.

    cheers, Paul

  • SimbaLion

    SimbaLion - 2016-08-24

    I have the same problem. CTRL-V auto type works with the pinentry window, but CTRL-ALT-A does not. It works in other windows. I think the issue is that the pinentry window is blocking any shortcut keys from working, as I tried others I have configured and they also do not work.

    I'd like to fix this, it is a nuisance.

    UPDATE: I found a solution by changing to the qt4 variation of pinentry. My CTRL-ALT-A shortcut now works.

    Last edit: SimbaLion 2016-08-24

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks