New Plugin - RDCAutoTypeAndTCATO

<< < 1 2 3 4 > >> (Page 2 of 4)
  • Pierre Roy

    Pierre Roy - 2009-09-21

    This plugin works also great with Citrix client. The name of the program you need to add in the program list is wfica32.exe


  • Piotr

    Piotr - 2009-09-21

    Thanks Pierre,

    Now wfica32.exe is on the default list of program that use the KeePass 1.x way of typing.

    Also - are there any thought about adding (or not) IE to that list?
    Some people have problems with IE and that possibly workes as one of workarrounds - but some people are fine without it.

    Piotr J.

  • Paul

    Paul - 2009-09-23

    IE problems are too varied to warrant inclusion in the default list.

    cheers, Paul

  • Ralf Krüger

    Ralf Krüger - 2009-12-13

    Absolutly essential plugin! Works fine, only one limitation: It seems that special sequences are not interpreted.

    I use this autotype-sequence in KeePass 1.1x: `%B{UserName}%K{Password}`

    But at the login-screen of RDP the **%B** and **%K** will not interpreted as **Alt-B/ALT-K** (jump to user). Instead they will be put as normal characters at the momentary ursor position. Does your plugin not support Key Modifiers *Shift: +, Control: ^, Alt: %* as described on  ?

    Regards, Ralf


  • Piotr

    Piotr - 2009-12-13

    Hi Ralf,

    Thank you for the nice words.
    I have turned of the plugin and tried Auto-Typing this seq.


    into notepad Alt-m being For**m**at for me.
    The whole entry got typed as is.

    So now I'm thinking what to do next. I guess we could tell the plugin to assume "%" means Alt. But would that be consistant with how 2.x workes. Just some random thoughts.

    Piotr J.

  • Ralf Krüger

    Ralf Krüger - 2009-12-14

    I can't confirm that: I installed KeePass V2.09 without any plugins on a Vista-System. When using an autotype sequence as… `{UserName} / {Password}%OS` …and starting in *Editor* KeePass interprets the special-keys without Problems and opens the assigned menus after sending username and password.

    Also have a look at this .

    Regards, Ralf


  • Piotr

    Piotr - 2009-12-14

    Hi Ralf,

    It wasn't working for me cause I had the % as part of the password. After using your presentation I got it working.
    BTW - the new plugin version  should have no problems with %. Correct?

    Cheers, Piotr


  • Ralf Krüger

    Ralf Krüger - 2009-12-15

    Hi Piotr!

    Correct: works absolutely great, no more problems!
    Here is a great beer for you: !(

    Thanks, Ralf

  • C. Jeppsen

    C. Jeppsen - 2009-12-16

    I agree with Ralf.  Just tried the plug in.  works great!

    Thanks, Cordell

  • C. Jeppsen

    C. Jeppsen - 2009-12-16

    What about vncviewer.exe?  We use that alot to make a console login to servers through a IP-enabled KVM.  I tried Keypass (GAT) with this and absolutely nothing works, although I don't know if it's related to the same problems solved here for RDP.

  • Paul

    Paul - 2009-12-19

    What happens with VNCviewer? Exact details please?

    cheers, Paul

  • Piotr

    Piotr - 2009-12-20

    Some programs like RDC in fullscreen block the Global AutoType Key (default Ctrl-Alt-A). This might be the case with vncviewer.exe?

    How about having vnc in the normal window (not full screen), and selecting Auto-Type from KeePass context menu.
    More details wellcome.


  • Ingo Dettmar

    Ingo Dettmar - 2010-01-04

    Hi Piotr,

    your plug-in just made my day! Thanks for providing this essential fix to the KeePass community. :)

    As Windows admins, we use Remote Desktop very frequently, and also applications hosted on terminal servers. In my opinion this is a serious shortcoming and should be fixed within the application itself eventually, not as a plug-in - Dominik, are you listening? ;-)


  • grigorescu

    grigorescu - 2010-02-11


    Version 0.5.8 doesn't work properly with double-quotes (").  To get it to work correctly, I had to replace the quote with a triple-double quote (""").  Can you please fix this?

    Thank you.

  • Piotr

    Piotr - 2010-02-12

    I have added the substitiution of " to """.
    Haven't changed the version no. You can download and test.

    Piotr J.

  • Anonymous - 2010-04-13

    I am very new to KeePass and I have 70 or so server I want to use KeePass for to automate login.  Can someone step me through how to get this to work using this plugin?  Thank you!

  • develop1

    develop1 - 2010-04-13

    not sure just how new you might to keepass
    or exactly how far you wish to go with automating.
    please excuse if I start too basic, or over reach.

    Here is one method, the advantage is it always works and requires very little setup or maintenance.
    Others might suggest something fancier but here's a basic.


    - assuming you copied the plx file to where keepass is installed (usually some folder of c:\program files\)
    - also assuming you defined a hot key for "auto-type selected entry key" typical value is:  "shift-ctrl-a" this is found under "tools" options" "intergration"
    - also assuming you defined a hot key for "show keepass window"  typical value is:  "shift-ctrl-c" this is found under "tools" "options" "intergration"
    - also assuming you want to use keepass with rdc (remote desktop connection ) which is windows executeable mstsc.exe


    launch keepass and create a new record
    in this record: 
       - title (whatever you want)
      - username (your username on the server you intend to connect to)
      - pasword (duh)
      - URL:    the string   cmd://"%windir%\system32\mstsc.exe" /v:XYX             (where XYZ is the server that you wish to connect)

    thats it.


    from now on when you wish to connect to server XYZ
    launch keepas (shfit-ctrl-c)
    find the xyz keepass record
    launch it (ctrl-u)
    login   (shfit-ctrl-a)


  • Anonymous - 2010-04-14

    WOW thanks for the freakin quick reply!! I had everything but this configured:

    "also assuming you defined a hot key for "auto-type selected entry key" typical value is: "shift-ctrl-a" this is found under "tools" options" "intergration"

    it works a treat!!! 

    there is one thing and i'm not sure if you ran into this as well -
    -The login (shift-ctrl-a) only works if the RDC window is not full screen.  I've tried to get around it by testing out Two-channel auto-type obfuscation and even entering the Target Window / Keystroke Sequence specifically.

    needless to say I am extremely grateful for your awesome help!!


  • Paul

    Paul - 2010-04-16

    Yes, RDC window must not be full screen. Nothing we can do about that.

    cheers, Paul

  • develop1

    develop1 - 2010-05-28

    Not sure if the following is considered a bug or not but I wanted to report it.

    An autotype into an RDC window correctly uses this pluggin and for the most part works perfectly.
    However inadvertently setting the caplock key causes a bad behavior ( this may or may not be a bug/preventable)

    to reproduce on your end. 
    create a keypass record with a mix case  username and mixed case password.
    in my example the username is -> ThisISaTestUsername    and its password is -> ThisISaTestPassword

    I then within an RDC connection I opened notepad and hit the hot key for "auto-type Selected Entry"

    if my caplocks are NOT set here is my autotype result (the case of each character is correct)…
    ThisISaTestUsername ThisISaTestPassword

    if my caplocks ARE set this is my autotype result (the case of each character is backwards)

  • Kev

    Kev - 2010-05-28

    That is normal Windows behaviour. I imagine when Keepass/RDC plugin do capitals, it (virtually) presses the shift key. This is inverted (as you have seen) when the CAPS lock is on.

    You can try it yourself. Turn on CAPS, and type a letter, then use shift + letter. It's inverted!

    Hope this explains things!

  • Piotr

    Piotr - 2010-05-29

    Now this plugin checks the state of capslock and internally inverts the lower/upper case (if capslock is on).
    So i should type correctly. Might be some problems with special functions - "^c" gets converted to "^C" and so on.
    Version number unchanged. Only plgx uploaded.
    Cheers, PJ

  • desolat

    desolat - 2010-09-14

    It seems the plugin does not work anymore for KeePass 2.13. Is there to be an update?

  • Gordon Watson

    Gordon Watson - 2010-09-14

    Yup, me too!

    looks like there's a timeout to check for updates, but I've yet to dig into the code  :(

    I get  a message "Plz check for a new version of this plugin"

  • Eric Jacobsson

    Eric Jacobsson - 2010-09-14

    I made a quick hack removing all the expiration code from the source, and it worked great. There was one occurence in  the VC project "ClasicType" and one in the VCS project "RDCAutoTypeAndTCATO". Then it was just to customize the batch file for creating the plugin and run it.
    I would put the binary for download if I only knew of a good place to put it.

<< < 1 2 3 4 > >> (Page 2 of 4)

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks