Clipboard Viewer Ignored

2011-05-25
2016-06-13
  • Dominik Reichl

    Dominik Reichl - 2011-05-25

    KeePass 2.x already has an option for this. 'Tools' -> 'Options' -> tab 'Security' -> option 'Use "Clipboard Viewer Ignore" clipboard format'.

    Up to now, the option is disabled by default, because in conjunction with the .NET/OLE clipboard functions it crashed the clipboard extender of Microsoft Office. However, KeePass 2.15 uses native Windows methods for putting data into the clipboard, and thus the Office crashing problem might not appear anymore. So, I'm thinking about enabling the option by default.

    Can anyone who has Office installed (with the clipboard extender) enable the 'Clipboard Viewer Ignore' option and test it?

    Thanks and best regards
    Dominik

     
    • fritzophrenic

      fritzophrenic - 2016-06-13

      Can anyone who has Office installed (with the clipboard extender) enable the 'Clipboard Viewer Ignore' option and test it?

      I enabled the "clipboard viewer ignore" option in KeePass and restarted KeePass. I launched Microsoft Word and brought up the clipboard dialog. I copied a few text items in Word to see that the clipboard viewer captures each item. I copied a username, and a password, in KeePass. Those items appear also. When the clipboard timeout expires in KeePass, the items do not go away. So although KeePass isn't crashing, I'm not sure the option is actually accomplishing anything.

      Am I doing something wrong?

       
  • Grindax

    Grindax - 2014-09-26

    Dominik, perhaps it's time to remove the '(not recommended)' from this option in the next version of KeePass?

     
  • Grindax

    Grindax - 2014-10-08

    The only reason I was asking is because this option seems to work fine for me.

     
  • Humangenom

    Humangenom - 2016-06-13
     
    Last edit: Humangenom 2016-06-13

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks