Help save net neutrality! Learn more.

WebDav and GMX sync

  • ch.dillen

    ch.dillen - 2013-06-15


    just new to KeePass and try to sync my Keypass2 files from windows over WebDav with my GMX media center.

    In Media Center I can see the file there, but I'm getting an error (404).

    Interestingly I can open the file via open url with the same path and user / password.

    Any ideas what is causing the issue.

    thx Christof

  • Paul

    Paul - 2013-06-16

    Sync requires write, rename and delete permission. Are these available to KeePass?

    cheers, Paul

  • hovwi

    hovwi - 2013-12-20

    have same probelms ,
    keepass are uploading a .tmp file tiil uncompete the file.
    after uploading keepass checking the .tmp file and try to rename the file to origin file name( whatever.kdbx).
    this renameing-process are chrashing in webdav conection.
    (read/write/rename rights , i think ) throw the file-floder and the .tmp file into online-trash-folder
    out fishing the .tmp file from the online trash folder and rename ist manualy in whatever.kdbx. that will work.
    keepass2 webdav process are not compatible to ( my experience)

  • wellread1

    wellread1 - 2013-12-21

    If renaming is causing the failure, try unchecking "Use file transactions for writing databases" in Tools>Options>Advanced(tab)>File Input/Output Connections(section). This feature was added as a default beginning with KeePass 2.09.

  • hovwi

    hovwi - 2013-12-22

    thx for answer.... i tested all combinations of settings in file input/output settings , also the same errors, whit out "use file transactions for writing " noting work .. seems like a essential setting ... i expect that are not 100% webdav rules conform... or keepass is not 100% conform, or both :)

  • wellread1

    wellread1 - 2013-12-23

    Perhaps you have a permissions issue. You must be able to create and delete files on via WebDav because KeePass will delete the old database and write a new one every time it saves.


Log in to post a comment.